More task bb clean up
[vuplus_openembedded] / recipes / tasks / task-opendreambox-enigma.bb
1 DESCRIPTION = "OpenDreambox: Enigma Task for the OpenDreambox Distribution"
2 SECTION = "opendreambox/base"
3 LICENSE = "MIT"
4 PR = "r0"
5
6 inherit task
7
8 PROVIDES = "\
9   task-opendreambox-ui \
10   ${PACKAGES} \
11 "
12
13 PACKAGES = "\
14   task-opendreambox-enigma \
15   task-opendreambox-modem \
16 "
17
18 #
19 # task-opendreambox-enigma
20 #
21 RPROVIDES_task-opendreambox-enigma = "task-opendreambox-ui"
22 DESCRIPTION_task-opendreambox-enigma = "OpenDreambox: Enigma Dependencies"
23 DEPENDS_task-opendreambox-enigma = "\
24   tuxbox-plugins \
25   tuxbox-plugins-enigma \
26   links-dream \
27 "
28 RDEPENDS_task-opendreambox-enigma = "\
29   enigma \
30   ipkgpl \
31   links-dream-plugin \
32   tuxbox-plugin-master \
33   tuxbox-plugin-mines  \
34   tuxbox-plugin-pacman \
35   tuxbox-plugin-snake \
36   tuxbox-plugin-soko \
37   tuxbox-plugin-sol \
38   tuxbox-plugin-solitair \
39   tuxbox-plugin-tank \
40   tuxbox-plugin-tetris \
41   tuxbox-plugin-tuxcom \
42   tuxbox-plugin-tuxmail \
43   tuxbox-plugin-tuxtxt \
44   tuxbox-plugin-vierg \
45   tuxbox-plugin-yahtzee \
46   enigma-locale-cs enigma-locale-da \
47   enigma-locale-de enigma-locale-el enigma-locale-es enigma-locale-et \
48   enigma-locale-fi enigma-locale-fr enigma-locale-hr enigma-locale-hu \
49   enigma-locale-is enigma-locale-it enigma-locale-lt enigma-locale-nl \
50   enigma-locale-no enigma-locale-pl enigma-locale-pt enigma-locale-ro \
51   enigma-locale-ru enigma-locale-sk enigma-locale-sl \
52   enigma-locale-sv enigma-locale-tr \
53   task-opendreambox-modem \
54 "
55
56 # disabled languages: enigma-locale-ar enigma-locale-sr enigma-locale-ur
57
58 RDEPENDS_task-opendreambox-enigma_append_dm7020 = "\
59   enigma-plugin-dreamdata \
60   tuxbox-plugin-lcdcirc \
61   tuxbox-plugin-satfind \
62 "
63  
64 RDEPENDS_task-opendreambox-enigma_append_dm600pvr = "\
65   enigma-blindscan \
66   dreambox-blindscan-utils \
67 "
68  
69 RDEPENDS_task-opendreambox-enigma_append_dm500plus = "\
70   enigma-blindscan \
71   dreambox-blindscan-utils \
72 "
73
74 PACKAGE_ARCH_task-opendreambox-enigma = "${MACHINE_ARCH}"
75
76 #
77 # task-opendreambox-modem
78 #
79 DESCRIPTION_task-opendreambox-modem = "OpenDreambox: Modem Support"
80 RDEPENDS_task-opendreambox-modem = "\
81   enigma-modem \
82   kernel-module-crc-ccitt \
83   kernel-module-ppp-async \
84   kernel-module-ppp-generic \
85   kernel-module-slhc \
86   update-modules \
87 "
88