add plugin(3g-modem-manager)
[vuplus_openembedded] / recipes / tasks / task-maemo.bb
1 DESCRIPTION = "Task package for maemo environment"
2 LICENSE = "MIT"
3 ALLOW_EMPTY = "1"
4 PR = "r1"
5
6 PACKAGES = "\
7     maemo-task-base \
8     maemo-task-apps \
9     maemo-task-libs-install \
10     maemo-task-theme"
11
12 RDEPENDS_maemo-base-depends = "\
13     diet-x11 \
14     virtual/xserver \
15     xpext \
16     xsp"
17
18 RDEPENDS_maemo-task-libs-install = "\
19     libsqlite \
20     hildon-lgpl \
21     libhildonbase \
22     libhildonwidgets \
23     hildon-fm"
24
25 RDEPENDS_maemo-task-base = "\
26     gdk-pixbuf-loader-png \
27     gdk-pixbuf-loader-xpm \
28     gdk-pixbuf-loader-jpeg \
29     pango-module-basic-x \
30     pango-module-basic-fc \
31     bluez-utils-dbus \
32     matchbox \
33     shared-mime-info \
34     rxvt-unicode \
35     xst \
36     xhost \
37     xrdb \
38     libgtkstylus \
39     outo \
40     hildon-initscripts \
41     libosso \
42     osso-af-utils \
43     osso-af-startup \
44     osso-core-config \
45     gnome-vfs \
46     osso-thumbnail \
47     xauth \
48     esd"
49
50 RDEPENDS_maemo-task-theme = "\
51     xcursor-transparent-theme \
52     sdk-default-theme \
53     sdk-default-theme-config \
54     sdk-default-icons \
55     sapwood \
56     ttf-bitstream-vera \
57     sapwood \
58     osso-sounds"
59
60 RDEPENDS_maemo-task-apps = "\
61     osso-gwobex \
62     osso-gwconnect \
63     osso-bttools \
64     hildon-status-bar \
65     hildon-home \
66     hildon-navigator \
67     hildon-control-panel \
68     osso-application-installer \
69     osso-app-killer \
70     osso-screenshot-tool \
71     gpe-todo-hildon \
72     gpe-contacts-hildon \
73     gpe-mini-browser-hildon"