task-vuplus-enigma2 : add remotecontrolcode plugin to uno & ultimo
[vuplus_openembedded] / recipes / tasks / task-gpephone.bb
1 DESCRIPTION = "Task packages for GPE Palmtop Environment Phone Edition"
2 PR = "r10"
3 LICENSE = "MIT"
4
5 inherit task
6
7 PACKAGES = "\
8     gpephone-task-base \
9     gpephone-task-settings \
10     gpephone-task-pim \
11     gpephone-task-connectivity \
12     gpephone-task-apps \
13     gpephone-task-development"
14
15 RDEPENDS_gpephone-task-development = "\
16     rxvt-unicode \
17     gpe-terminal \
18     gpe-edit \
19     gdb \
20     strace \
21     e2fsprogs \
22     bluez-utils-compat \
23     minicom"
24
25 RDEPENDS_gpephone-task-base = "\
26     cms92init \
27     gsmmux \
28     connect \
29     phoneserver \
30     soundserver \
31     voicecall \
32     vochistory \
33     sms \
34     audioplayer \
35     videoplayer \
36     addressbook \
37     calendar \
38     gpe-applauncher \
39     gpe-phonepanel \
40     gpe-bootsplash \
41     gpe-bootsplash-theme-gpephone \
42     bluez-utils-dbus \
43     matchbox \
44     xcursor-transparent-theme \
45     gtk2-theme-angelistic \
46     matchbox-themes-gtk \
47     xst \
48     xhost \
49     xrdb \
50     gpe-soundserver \
51     ttf-bitstream-vera \
52     ttf-dejavu-sans \
53     ttf-dejavu-sans-mono \
54     gpe-dm \
55     gpe-login \
56     gpe-session-scripts-phone \
57     gpe-icons \
58     gpe-confd \
59     gpe-autostarter \
60     xauth \
61     gdk-pixbuf-loader-png \
62     gdk-pixbuf-loader-xpm \
63     gdk-pixbuf-loader-jpeg \
64     gdk-pixbuf-loader-gif \
65     pango-module-basic-x \
66     pango-module-basic-fc \
67     detect-stylus \
68     ptim-manager \
69     ptim-helper \
70     ptim-engine \
71     ${@base_contains("MACHINE_FEATURES", "touchscreen", "libgtkstylus xtscal", "",d)} \
72 "
73
74 RDEPENDS_gpephone-task-pim = "\
75      gpesyncd"
76
77 RDEPENDS_gpephone-task-settings = "\
78     gpe-su \
79     gpe-conf \
80     gpe-mixer \
81     gpe-taskmanager \
82     minilite \
83     machined"
84
85 RDEPENDS_gpephone-task-apps = "\
86     gpe-what \
87     gpe-scap \
88     gpe-windowlist"
89
90 RDEPENDS_gpephone-task-connectivity = "\
91 "