More task bb clean up
[vuplus_openembedded] / recipes / tasks / task-fso-toolchain-target.bb
1 DESCRIPTION = "Packages for a standalone  SDK or external toolchain"
2 LICENSE = "MIT"
3 ALLOW_EMPTY = "1"
4
5 PR = "r1"
6
7 PACKAGES = "${PN}"
8
9 # Stuff contained in this SDK is largely taken from task-sdk-base.bb.
10 # This is a starting point, and nothing more at present -- please fill
11 # this out with a reasonable set of development tools for an FSO image.
12 # Also feel free to remove stuff that's silly.  And someone should
13 # review the glibc-gconv list to see if that makes sense.
14
15 RDEPENDS_${PN} = "\
16     glibc \
17     glibc-dbg \
18     glibc-dev \
19     glibc-utils \
20     libsegfault \
21     glibc-thread-db \
22     glibc-localedata-i18n \
23     glibc-gconv-ibm850 \
24     glibc-gconv-cp1252 \
25     glibc-gconv-iso8859-1 \
26     glibc-gconv-iso8859-15 \
27     locale-base-en-gb \
28     libgcc \
29     libstdc++ \
30     linux-libc-headers-dev \
31     \
32     libssl \
33     libcrypto \
34     openssl-dev \
35     libts-dev \
36     ncurses-dev \
37     readline-dev \
38     gnutls-dev \
39     libgcrypt-dev \
40     libapm-dev \
41     alsa-dev \
42     alsa-lib-dev \
43     libgpg-error-dev \
44     libx11-dev \
45     util-macros-dev \
46     bigreqsproto-dev \
47     xproto-dev \
48     xextproto-dev \
49     xtrans-dev \
50     xcmiscproto-dev \
51     xf86bigfontproto-dev \
52     kbproto-dev \
53     inputproto-dev \
54     glib-2.0-dev \
55     expat-dev \
56     libice-dev \
57     libsm-dev \
58     dbus-dev \
59     bluez-libs-dev \
60     jpeg-dev \
61     libpng-dev \
62     "
63
64 # This one needs further investigation; seems to be some
65 # sort of naming problem that breaks the SDK when it is
66 # added directly.
67 ODDLY_BROKEN_PACKAGES ="\
68     libz-dev \
69 "