More task bb clean up
[vuplus_openembedded] / recipes / tasks / task-fonts-truetype.bb
1 DESCRIPTION = "Install one of these tasks to get support for truetype fonts."
2 SECTION = "fonts"
3 LICENSE = "MIT"
4 PV = "1.0"
5 PR = "r0"
6
7 inherit task
8
9 PACKAGES += "\
10   ${PN}-core \
11   ${PN}-chinese \
12   ${PN}-japanese \
13 "
14
15 RRECOMMENDS_task-fonts-truetype = "\
16   ${PN}-core \
17   ${PN}-chinese \
18   ${PN}-japanese \
19 "
20
21 RDEPENDS_task-fonts-truetype-core = "\
22   fontconfig-utils \
23   \
24   ttf-dejavu-common \
25   ttf-dejavu-sans \
26 #  ttf-dejavu-serif \
27   ttf-dejavu-sans-mono \
28 "
29
30 RDEPENDS_task-fonts-truetype-chinese = "\
31   ${PN}-core \
32   ttf-arphic-uming \
33 "
34
35 RDEPENDS_task-fonts-truetype-japanese = "\
36   ${PN}-core \
37   ttf-sazanami-gothic \
38   ttf-sazanami-mincho \
39 "