task-vuplus-enigma2.bb : append led brightness setup, ultimo
[vuplus_openembedded] / recipes / tasks / angstrom-task-gnome.bb
1 DESCRIPTION = "Task for a GNOME based image"
2
3 inherit task
4
5 # Most of these tasks are arch independant
6 PACKAGE_ARCH = "all"
7
8 XSERVER ?= "xserver-xorg \
9            xf86-input-evdev \
10            xf86-input-mouse \
11            xf86-video-fbdev \
12            xf86-input-keyboard \
13 "
14
15 PR = "r5"
16
17 PACKAGES += "task-gnome-apps task-gnome-fonts task-gnome task-gnome-gstreamer task-gnome-perl task-gnome-pulseaudio task-gnome-themes task-gnome-totem task-gnome-xserver-base task-gnome-xserver"
18
19 DEPENDS = "gst-plugins-ugly"
20
21 RDEPENDS_task-gnome-apps = " \
22   abiword \
23   cheese \
24   claws-mail \
25   epiphany epiphany-extensions \
26   swfdec swfdec-gnome swfdec-mozilla \
27   evince \
28   gcalctool \
29   gedit \
30   gimp \
31   gnome-games \
32   gnome-mplayer \
33   gnumeric \
34   gphoto2 \
35   gthumb \
36   pidgin \
37   synergy \
38   vnc \
39   x11vnc angstrom-x11vnc-xinit \
40   xmms \
41   xterm \
42   eog \
43  "
44
45 RDEPENDS_task-gnome-fonts = " \
46   font-adobe-75dpi \
47   fontconfig fontconfig-utils font-util \
48   ttf-arphic-uming \
49   ttf-dejavu-common \
50   ttf-dejavu-sans \
51   ttf-dejavu-serif \
52   ttf-dejavu-sans-mono \
53   ttf-liberation-sans \
54   ttf-liberation-serif \
55   ttf-liberation-mono \
56   xorg-minimal-fonts \
57  "  
58
59 RDEPENDS_task-gnome = " \
60   at-spi \
61   file-roller \
62   gconf gconf-editor \
63   gdm \
64   gnome-control-center \
65   gnome-applets \
66   gnome-bluetooth \
67   gnome-desktop \
68   gnome-doc-utils \
69   gnome-keyring gnome-keyring-pam-plugin libpam-meta \
70   gnome-media \
71   gnome-menus \
72   gnome-mime-data \
73 #  gnome-packagekit packagekit packagekit-gtkmodule \
74   gnome-panel libpanel-applet libgweather-locationdata\
75   gnome-power-manager gnome-power-manager-applets \
76   gnome-python gnome-python-extras \
77   gnome-python-desktop \
78   gnome-screensaver \
79   gnome-session \
80   gnome-settings-daemon \
81   gnome-system-monitor \
82   gnome-system-tools system-tools-backends\
83   gnome-terminal \
84   gnome-utils \
85   gnome-vfs \
86   gnome-vfs-plugin-bzip2 \
87   gnome-vfs-plugin-computer \
88   gnome-vfs-plugin-dns-sd \
89   gnome-vfs-plugin-file \
90   gnome-vfs-plugin-ftp \
91   gnome-vfs-plugin-gzip \
92   gnome-vfs-plugin-http \
93   gnome-vfs-plugin-network \
94   gnome-vfs-plugin-nntp \
95   gnome-vfs-plugin-sftp \
96   gnome-vfs-plugin-tar \
97   gvfs \
98   metacity \
99   nautilus nautilus-cd-burner desktop-file-utils\
100   networkmanager network-manager-applet networkmanager-openvpn \
101   policykit-gnome policykit \
102   zenity \
103  "
104
105 DEPENDS_task-gnome-gstreamer = " \
106   gst-plugins-base \
107   gst-plugins-good \
108   gst-plugins-bad \
109   gst-plugins-ugly \
110 "
111
112 RDEPENDS_task-gnome-gstreamer = " \
113   gst-ffmpeg \
114   gst-plugin-pulse \
115   gst-plugins-base-meta \
116   gst-plugins-good-meta \
117   gst-plugins-bad-meta \
118   gst-plugins-ugly-meta \
119 "
120
121 RDEPENDS_task-gnome-perl = " \
122   perl \
123   task-perl-module-all \
124   libnet-dbus-perl \
125   libxml-parser-perl \
126   libxml-twig-perl \
127 "
128
129 RDEPENDS_task-gnome-cups = " \
130   cups \
131   cups-backend-hal \
132 #  cups-gs \
133   gnome-cups-manager \
134   gtk-printbackend-cups \
135 #  gutenprint \
136   hal-cups-utils \
137  "
138
139 RDEPENDS_task-gnome-pulseaudio = " \
140   pulseaudio-alsa-wrapper \
141   pulseaudio-esd-wrapper \
142   pulseaudio-module-gconf \
143   libasound-module-ctl-pulse \
144   libasound-module-pcm-pulse \
145  "
146
147 RDEPENDS_task-gnome-themes = " \
148   angstrom-gnome-icon-theme-enable \
149   gnome-icon-theme \
150   gnome-themes \
151   gtk-engine-clearlooks \
152   gtk-engine-glide \
153   gtk-engine-thinice \
154   gtk-engine-redmond95 \
155   gtk-theme-clearlooks \
156   gtk-theme-thinice \
157   gtk-theme-redmond \
158   hicolor-icon-theme \
159   sound-theme-freedesktop \
160  "
161
162 RDEPENDS_task-gnome-totem = " \
163   totem \
164   totem-browser-plugin \
165   totem-plugin-bemused \
166   totem-plugin-gromit \
167   totem-plugin-media-player-keys \
168   totem-plugin-ontop \
169   totem-plugin-properties \
170   totem-plugin-screensaver \
171   totem-plugin-skipto \
172   totem-plugin-thumbnail \
173  "
174
175 RDEPENDS_task-gnome-xserver-base = " \
176   dbus-x11 \
177   desktop-file-utils \
178   iso-codes \
179   mime-support \
180   notification-daemon inotify-tools \
181   xauth \
182   xdg-utils \
183   xhost \
184   xinetd \
185   xinit \
186   xlsfonts \
187   xrandr \
188   xrdb \
189   xrefresh \
190   xset \
191   xvinfo \
192  "
193
194 RDEPENDS_task-gnome-xserver = " \
195   ${XSERVER} \
196 "
197
198 PACKAGE_ARCH_task-gnome-xserver = "${MACHINE_ARCH}"
199
200 RDEPENDS_${PN} = " \
201   task-gnome-apps \
202   task-gnome-fonts \
203   task-gnome \
204   task-gnome-gstreamer \
205   task-gnome-perl \
206   task-gnome-perl \
207   task-gnome-pulseaudio \
208   task-gnome-themes \
209   task-gnome-totem \
210   task-gnome-xserver-base \
211 "
212
213 RRECOMMENDS_${PN} = " \
214    task-gnome-xserver \
215 "
216