surpport seeking the recorded video
[vuplus_openembedded] / recipes / syslinux / syslinux_3.82.bb
1 # syslinux OE build file
2 # Copyright (C) 2009, O.S. Systems Software Ltda.  All Rights Reserved
3 # Released under the MIT license (see packages/COPYING)
4
5 DESCRIPTION = "A multi-purpose linux bootloader"
6 HOMEPAGE = "http://syslinux.zytor.com/"
7 LICENSE = "GPL"
8 DEPENDS = "nasm-native"
9 RRECOMMENDS_${PN} = "mtools"
10 PR = "r0"
11
12 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/syslinux-${PV}.tar.bz2 "
13
14 EXTRA_OEMAKE = " \
15         BINDIR=${bindir} SBINDIR=${base_sbindir} LIBDIR=${libdir} \
16         DATADIR=${datadir} MANDIR=${mandir} INCDIR=${includedir} \
17 "
18
19 do_configure() {
20         # drop win32 targets or build fails
21         sed -e 's,win32/\S*,,g' -i Makefile
22
23         # clean installer executables included in source tarball
24         oe_runmake clean
25 }
26
27 do_compile() {
28         # Rebuild only the installer; keep precompiled bootloaders
29         # as per author's request (doc/distrib.txt)
30         oe_runmake CC="${CC}" installer
31 }
32
33 do_install() {
34         oe_runmake install INSTALLROOT="${D}"
35 }
36
37 PACKAGES =+ "${PN}-extlinux ${PN}-mbr"
38 FILES_${PN} = "${bindir}/syslinux"
39 FILES_${PN}-extlinux = "${base_sbindir}/extlinux"
40 FILES_${PN}-mbr = "${datadir}/${PN}/mbr.bin"
41 FILES_${PN}-dev += "${datadir}/${PN}/com32"