surpport seeking the recorded video
[vuplus_openembedded] / recipes / sylpheed / claws-mail_3.6.1.bb
1 SECTION = "x11/network"
2 DESCRIPTION = "Mail user agent"
3 DEPENDS = "gtk+ libetpan openssl aspell"
4 LICENSE = "GPL"
5 PR = "r1"
6
7 inherit autotools pkgconfig
8
9 # translation patch: http://www.thewildbeast.co.uk/claws-mail/bugzilla/show_bug.cgi?id=1774
10 SRC_URI = "\
11         ${SOURCEFORGE_MIRROR}/sylpheed-claws/claws-mail-${PV}.tar.bz2 \
12         http://www.penguin.cz/~utx/ftp/claws-mail/claws-mail-${PV}-po-update.patch;patch=1 \
13         file://desktop.patch;patch=1 \
14         file://claws-mail-g_strcmp0.patch;patch=1 \
15         "
16
17 do_configure_append() {
18         cd po ; for PO in *.po ; do MO=`echo $PO | sed s/\\.po//`.gmo ; if ! test -f $MO ; then msgfmt $PO -o $MO ; fi ; done
19 }
20
21 # FIXME: maemo builds may want --enable-maemo
22 # FIXME: some platforms may want --enable-generic-umpc
23 EXTRA_OECONF = "--disable-aspell-test           \
24                 --enable-aspell                 \
25                 --disable-manual                \
26                 --disable-crash-dialog          \
27                 --disable-jpilot                \
28                 --disable-trayicon-plugin       \
29                 --disable-spamassassin-plugin   \
30                 --disable-bogofilter-plugin     \
31                 --disable-pgpcore-plugin        \
32                 --disable-pgpmime-plugin        \
33                 --disable-pgpinline-plugin      \
34                 --disable-dillo-viewer-plugin   \
35                 --disable-clamav-plugin         \
36                 --disable-gnomeprint            \
37                 --disable-valgrind              \
38                 "
39
40 # Remove enchant references:
41 do_install_prepend() {
42         sed -i -e 's:${STAGING_INCDIR}:${includedir}:g;s:${STAGING_LIBDIR}:${libdir}:g' claws-mail.pc
43 }
44
45 # Work-around broken GPE icon lookup:
46 do_install_append() {
47         rm -r ${D}${datadir}/icons
48         install -d ${D}${datadir}/pixmaps
49         install -m 0644 claws-mail.png ${D}${datadir}/pixmaps/
50         sed -i 's/Icon=[^.]*$/&.png/' ${D}${datadir}/applications/claws-mail.desktop
51 }
52
53 do_stage() {
54         autotools_stage_includes
55 }