surpport seeking the recorded video
[vuplus_openembedded] / recipes / sugar / sugar-base_0.83.2.bb
1 DESCRIPTION = "Sugar base system"
2 LICENSE = "LGPLv2"
3
4 PR = "r1"
5
6 DEPENDS = "python-pygtk sugar-toolkit"
7 RDEPENDS = "librsvg-gtk \
8             ohm-plugin-x11 ohm \
9             hippo-canvas \
10             python-datetime \
11             python-netclient \
12             python-pygtk \
13             sugar-toolkit \
14             python-logging \
15             python-dbus \
16             python-subprocess \
17             telepathy-gabble telepathy-salut telepathy-python \
18             sugar-presence-service \
19             python-crypt \
20             python-numpy \
21             python-compression \
22             python-gst \
23             python-simplejson \
24             python-misc \
25             python-xmlrpc \
26             python-compiler \
27             python-pydoc \
28             python-mmap \
29             python-doctest \
30             ssh-keygen"
31
32 inherit gnome distutils-base
33
34 SRC_URI = "http://download.sugarlabs.org/sources/sucrose/glucose/sugar-base/${PN}-${PV}.tar.bz2"
35
36 SRC_URI += "file://acinclude.m4"
37
38 EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
39
40 do_configure_prepend() {
41         install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
42 }
43
44 FILES_${PN} += "${datadir}/${PN} \
45                 ${datadir}/dbus-1 \
46                 ${sysconfdir} "
47
48 FILES_${PN}-dbg += "${libdir}/python*/site-packages/sugar/.debug"
49
50 AUTOTOOLS_STAGE_PKGCONFIG = "1"
51
52 do_stage() {
53         autotools_stage_all
54 }
55