surpport seeking the recorded video
[vuplus_openembedded] / recipes / slutils / slutils_0.1.0.bb
1 DESCRIPTION = "Console utilities for certain hardware aspects of Sharp Linux based Zaurii"
2 DESCRIPTION_slfb = "A command-line utility to turn on/off the FrameBuffer on Linux 2.4-based Zaurii"
3 DESCRIPTION_slbl = "A command-line utility to control the BackLight on Linux 2.4-based Zaurii"
4 DESCRIPTION_sltime = "A ustility to save and restore the time on Sharp Linux based Zaurii"
5 SECTION = "console/utils"
6 PRIORITY = "optional"
7 LICENSE = "GPL"
8 PR = "r4"
9
10 inherit qmake update-rc.d
11
12 SRC_URI = "file://sltime.sh"
13
14 INITSCRIPT_NAME = "sltime"
15 INITSCRIPT_PARAMS = "defaults 5"
16
17 export UTILS = "sltime slbl slfb"
18
19 do_fetch() {
20         for u in ${UTILS}
21         do
22                 install -d ${S}/$u
23                 cp -PfR `ls -dp ${FILESDIR}/$u/*|grep -v SCCS` ${S}/$u/
24         done
25 }
26
27 do_configure_prepend() {
28         cd ${S}/
29         printf "TEMPLATE=subdirs\nSUBDIRS=${UTILS}\n" >slutils.pro
30 }
31
32 do_install() {
33         install -d ${D}${sbindir}
34         for u in ${UTILS}
35         do
36                 install -m 0755 ${S}/${u}/${u} ${D}${sbindir}/
37         done
38         install -d ${D}${sysconfdir}/init.d/
39         install -m 0755 ${WORKDIR}/sltime.sh ${D}${sysconfdir}/init.d/sltime
40 }
41
42 PACKAGES =+ "slbl slfb"
43 FILES_slbl = "${sbindir}/slbl"
44 FILES_slfb = "${sbindir}/slfb"
45