surpport seeking the recorded video
[vuplus_openembedded] / recipes / shfs / shfs-utils_0.35.bb
1 DESCRIPTION = "A simple and easy to use Linux kernel (2.4+) module which allows you to mount remote filesystems using plain shell (ssh/rsh) connection. \
2 It supports some nice features like number of different caches for access speedup, target system optimisations, etc."
3 SECTION = "kernel/userland"
4 PRIORITY = "optional"
5 LICENSE = "GPL"
6 RDEPENDS = "shfs-modules (${PV})"
7 DEPENDS = "virtual/kernel"
8
9 SRC_URI = "${SOURCEFORGE_MIRROR}/shfs/shfs-${PV}.tar.gz"
10 S = "${WORKDIR}/shfs-${PV}/shfsmount"
11
12 KERNEL_VERSION = "${@base_read_file('${STAGING_KERNEL_DIR}/kernel-abiversion')}"
13 KV = "${@base_read_file('${STAGING_KERNEL_DIR}/kernel-abiversion')[:3]}"
14
15 CFLAGS_append=' -DVERSION=\\"${KERNEL_VERSION}\\" -DSHFS_VERSION=\\"${PV}\\" -I../shfs/Linux-${KV}'
16
17 do_compile() {
18         oe_runmake LINKER="${CC}"
19 }
20
21 do_install() {
22         install -d ${D}${bindir}
23         install -m 0755 shfsmount shfsumount ${D}${bindir}
24 }