surpport seeking the recorded video
[vuplus_openembedded] / recipes / sharp-binary-only / sharp-aticore-oss_1.0.1.bb
1 DESCRIPTION = "Driver for the Ati W100 found on the Sharp Zaurus C[87]x0"
2 SECTION = "libs"
3 PRIORITY = "optional"
4 LICENSE = "CLOSED"
5 PR = "r4"
6
7 SRC_URI = "http://mirror1.pdaxrom.org/source/src/AtiCore-1.0.1.tar.bz2 \
8                 file://fixstretchblit.patch;patch=1 \
9                 file://aticore-2.6.patch;patch=1 \
10                 file://make381.patch;patch=1"
11 S = "${WORKDIR}/AtiCore-1.0.1"
12
13 EXTRA_OEMAKE="CC='${CC}' AS='${AS}' AR='${AR}' LD='${LD}' FPU='${TARGET_FPU}'"
14
15 PARALLEL_MAKE = ""
16 COMPATIBLE_MACHINE = 'c7x0'
17
18 do_install() {
19         install -d ${D}${bindir}
20         install -m 0755 testcore ${D}${bindir}/testcore
21         install -m 0755 atitest ${D}${bindir}/atitest
22
23         install -d ${D}${libdir}
24         install -m 0755 libaticore.so.1.0.1 ${D}${libdir}/libaticore.so.1.0.1
25
26         install -d ${D}${includedir}
27         install -m 0644 aticore.h ${D}${includedir}/aticore.h
28
29         cd ${D}${libdir}/
30         ln -s libaticore.so.1.0.1 libaticore.so.1
31         ln -s libaticore.so.1.0.1 libaticore.so.1.0
32         ln -s libaticore.so.1.0.1 libaticore.so
33 }
34
35 # Currently incompatible with the way sharp-aticore.bb stages.
36 do_stage() {
37         install -m 0644 aticore.h ${STAGING_INCDIR}
38         oe_libinstall -so libaticore ${STAGING_LIBDIR}
39 }
40
41 PACKAGES =+ "sharp-aticore-oss-examples"
42 FILES_sharp-aticore-oss-examples = "${bindir}"
43