surpport seeking the recorded video
[vuplus_openembedded] / recipes / reiser4progs / reiser4progs_1.0.4.bb
1 # This package builds tools to manipulate Reiser4 file systems,
2 # the libaal package must be built and installed as well to
3 # run these tools.
4 PR = "r1"
5 DESCRIPTION = "User-level tools for Reiser4 filesystems"
6 HOMEPAGE = "http://www.namesys.com"
7 SECTION = "base"
8 LICENSE = "GPLv2"
9
10 SRC_URI = "ftp://ftp.namesys.com/pub/${PN}/old-versions/${P}.tar.gz \
11                 file://oid40.c.patch;patch=1 \
12                 file://key_short.c.patch;patch=1 \
13                 file://key_large.c.patch;patch=1 \
14                 file://align.patch;patch=1"
15
16 LIBAAL = "libaal"
17
18 DEPENDS = "${LIBAAL}"
19
20 # This disables anything which uses libminimal - that library
21 # is used for boot loader stuff and so is not required unless
22 # the system will boot from a Reiser4 file system, the same
23 # setting must exist for the LIBAAL build
24 DISABLE_LIBMINIMAL ?= "--disable-libminimal"
25 EXTRA_OECONF = "${DISABLE_LIBMINIMAL}"
26
27 LEAD_SONAME = "libreiser4"
28
29 inherit autotools