surpport seeking the recorded video
[vuplus_openembedded] / recipes / quake / quetoo_0.6.1.bb
1 DESCRIPTION = "Initially a fork of the Quake2Forge project, this engine aims to provide security and performance enhancements."
2 LICENSE = "GPLv2"
3
4 DEPENDS = "libsdl-x11 zlib virtual/libgl"
5 SRC_URI = "http://tastyspleen.net/~jdolan/quetoo-${PV}.tar.bz2"
6
7 PR = "r1"
8 inherit autotools pkgconfig
9
10
11 EXTRA_OECONF = "\
12                --with-games=baseq2 \
13                --with-sdl \
14                --with-zlib \
15                "
16
17 do_configure() {
18         for i in ctf qmass vanctf ; do
19                 mkdir -p ${S}/data/$i/sound
20                 mkdir -p ${S}/data/$i/maps 
21                 mkdir -p ${S}/src/$i
22                 touch ${S}/data/$i/Makefile.in
23                 touch ${S}/data/$i/sound/Makefile.in
24                 touch ${S}/data/$i/maps/Makefile.in
25                 touch ${S}/src/$i/Makefile.in   
26         done
27
28         sed -i -e s:-Werror::g ${S}/configure
29         gnu-configize --force
30         oe_runconf
31         rm config.log
32 }
33
34 do_install_append() {
35         mv ${D}${bindir}/${TARGET_PREFIX}quetoo ${D}${bindir}/quetoo
36 }
37
38 FILES_${PN}-dbg += "${libdir}/quetoo/baseq2/.debug"