surpport seeking the recorded video
[vuplus_openembedded] / recipes / qpphoto / qpphoto_1.0.2.bb
1 DESCRIPTION = "Painting program. Small picture editor."
2 HOMEPAGE = "http://zaurus.colognearts.de/qpphoto/"
3 SECTION = "opie/applications"
4 PRIORITY = "optional"
5 LICENSE = "GPL"
6 APPNAME = "qpPhoto"
7 APPTYPE = "binary"
8 APPDESKTOP = "${S}"
9
10 PR = "r0"
11
12 inherit opie
13
14 SRC_URI = "http://zaurus.colognearts.de/qpphoto/qpPhoto_1.0.2_src.tar.gz \
15            file://draw.patch;patch=1 \
16            file://drawview.patch;patch=1 \
17            file://drawwidget.patch;patch=1 "
18
19 S = "${WORKDIR}/qpPhoto_1.0.2"
20
21 do_compile() {
22         export STAGING_BINDIR=${STAGING_BINDIR}
23         oe_runmake clean
24         oe_runmake
25 }
26
27 do_install() {
28 #       install -d ${D}${palmtopdir}/apps/Applications
29         install -d ${D}${palmtopdir}/pics
30 #       install -d ${D}${bindir}
31
32         install -m 0644 qpPhoto.png ${D}${palmtopdir}/pics
33 #       install -m 0644 qpPhoto.desktop ${D}${palmtopdir}/apps/Applications
34 #       install -m 0755 qpPhoto ${D}${bindir}
35 }
36
37 # FILES_${PN} = " ${palmtopdir}/apps/Applications/qpPhoto.desktop ${palmtopdir}/pics/qpPhoto.png ${bindir}/qpPhoto "