Merge branch 'vuplus-1.6' of 192.168.102.66:/var/ikseong/repo/openembedded into test_0921
[vuplus_openembedded] / recipes / python / python-native_2.6.7.bb
1 require python.inc
2 DEPENDS = "openssl-native bzip2-full-native zlib-native readline-native"
3 PR = "${INC_PR}.0"
4
5 SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2;name=archive \
6            file://00-fix-parallel-make.patch;patch=1 \
7            file://04-default-is-optimized.patch;patch=1 \
8            file://05-enable-ctypes-cross-build.patch;patch=1 \
9            file://06-ctypes-libffi-fix-configure.patch;patch=1 \
10            file://10-distutils-fix-swig-parameter.patch;patch=1 \
11            file://11-distutils-never-modify-shebang-line.patch;patch=1 \
12            file://12-distutils-prefix-is-inside-staging-area.patch;patch=1 \
13            file://debug.patch;patch=1 \
14            file://nohostlibs.patch;patch=1"
15
16 S = "${WORKDIR}/Python-${PV}"
17
18 inherit native
19
20 EXTRA_OECONF_append = '\
21   --enable-unicode=ucs4 \
22 '
23
24 EXTRA_OEMAKE = '\
25   BUILD_SYS="" \
26   HOST_SYS="" \
27   LIBC="" \
28   STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE} \
29   STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \
30 '
31
32 do_stage_append() {
33         install -m 0755 Parser/pgen ${STAGING_BINDIR_NATIVE}/pgen
34 }