surpport seeking the recorded video
[vuplus_openembedded] / recipes / prelink / prelink_20090925.bb
1 SECTION = "devel"
2 DEPENDS = "elfutils"
3 DESCRIPTION = " The prelink package contains a utility which modifies ELF shared libraries \
4 and executables, so that far fewer relocations need to be resolved at \
5 runtime and thus programs come up faster."
6 LICENSE = "GPL"
7
8 SRC_URI = "${DEBIAN_MIRROR}/main/p/prelink/prelink_0.0.${PV}.orig.tar.gz \
9            file://prelink.conf \
10            file://prelink.cron.daily \
11            file://prelink.default"
12
13 #TARGET_OS_ORIG := "${TARGET_OS}"
14 #OVERRIDES_append = ":${TARGET_OS_ORIG}"
15 #SRC_URI_append_linux-gnueabi = " file://arm_eabi.patch;patch=1"
16
17 S = "${WORKDIR}/prelink-0.0.${PV}"
18
19 EXTRA_OECONF = "--disable-64bit"
20
21 inherit autotools 
22
23 do_install_append () {
24         install -d ${D}${sysconfdir}/cron.daily ${D}${sysconfdir}/default
25         install -m 0644 ${WORKDIR}/prelink.conf ${D}${sysconfdir}/prelink.conf
26         install -m 0644 ${WORKDIR}/prelink.cron.daily ${D}${sysconfdir}/cron.daily/prelink
27         install -m 0644 ${WORKDIR}/prelink.default ${D}${sysconfdir}/default/prelink
28 }
29
30 pkg_postinst_prelink() {
31 #!/bin/sh
32
33 if [ "x$D" != "x" ]; then
34   exit 1
35 fi
36
37 . ${sysconfdir}/cron.daily/prelink
38 }
39
40 pkg_prerm_prelink() {
41 #!/bin/sh
42
43 if [ -f ${sysconfdir}/prelink.cache ]; then
44     prelink -au
45     rm -f ${sysconfdir}/prelink.cache
46 fi
47 }
48