[hbbtv/youtubetv] Fixed hanup bug and segmentation fault on 3rd-party images.
[vuplus_openembedded] / recipes / opkg / opkg_svn.bb
1 require opkg.inc
2
3 DEPENDS_append = " openssl"
4
5 PR = "${INC_PR}"
6
7 PROVIDES =+ "virtual/update-alternatives"
8 RPROVIDES_${PN} = "update-alternatives"
9 PACKAGES =+ "libopkg-dev libopkg"
10 RPROVIDES_${PN} += "update-alternatives"
11
12 FILES_libopkg-dev = "${libdir}/*.a ${libdir}/*.la ${libdir}/*.so"
13 FILES_libopkg = "${libdir}/*.so.*"
14 # not happens automatically for opkg-nogpg:
15 FILES_${PN} += "${datadir}/opkg/intercept"
16
17 # Define a variable to allow distros to run configure earlier.
18 # (for example, to enable loading of ethernet kernel modules before networking starts)
19 OPKG_INIT_POSITION = "98"
20 OPKG_INIT_POSITION_slugos = "41"
21
22 pkg_postinst_${PN} () {
23   update-alternatives --install ${bindir}/opkg opkg ${bindir}/opkg-cl 100
24 }
25
26 pkg_postrm_${PN} () {
27   update-alternatives --remove opkg ${bindir}/opkg-cl
28 }