Merge commit 'opendreambox/opendreambox-1.6' into vuplus-1.6
[vuplus_openembedded] / recipes / opkg / opkg-nogpg_svn.bb
1 require opkg_svn.bb
2
3 DEPENDS = "curl"
4 PROVIDES += "opkg"
5
6 PR = "${INC_PR}.1"
7
8 SRCREV = "${SRCREV_pn-opkg}"
9
10 EXTRA_OECONF += " --disable-gpg \ 
11                   --disable-openssl \ 
12                   --disable-ssl-curl \
13                   --enable-gpg=no \
14                   --enable-ssl-curl=no \
15                   --enable-openssl=no"
16
17 LDFLAGS_append = " -Wl,--as-needed"
18
19 PV_opendreambox = "0.1.7+svnr${SRCPV}"
20 SRC_URI_append_opendreambox = " file://remove_pyc_pyo_hack.patch;patch=1;pnum=1 "
21 PV_vuplus = "0.1.7+svnr${SRCPV}"
22 SRC_URI_append_vuplus = " file://remove_pyc_pyo_hack.patch;patch=1;pnum=1 "
23
24 # The nogpg version isn't getting much love and has an unused variable which trips up -Werror
25 do_configure_prepend() {
26         sed -i -e s:-Werror::g ${S}/libopkg/Makefile.am
27 }
28 do_configure_prepend_nylon() {
29         LDFLAGS="`echo "$LDFLAGS" | sed "s/ -Wl,--as-needed//"`"
30 }
31
32 DEFAULT_PREFERENCE = "-1"