surpport seeking the recorded video
[vuplus_openembedded] / recipes / opensync / libsyncml_svn.bb
1 DESCRIPTION = "Libsyncml is a implementation of the SyncML protocol."
2 HOMEPAGE = "http://libsyncml.opensync.org/"
3 LICENSE = "LGPL"
4
5 DEPENDS = "sed-native wbxml2 libsoup libxml2 bluez-libs openobex"
6
7 PV = "0.4.2+svn${SRCDATE}"
8 SRC_URI = "svn://svn.opensync.org/libsyncml;module=trunk;proto=http"
9 S = "${WORKDIR}/trunk"
10
11 inherit autotools pkgconfig
12
13 EXTRA_OECONF = " --enable-http \
14                  --enable-obex \
15                  --enable-bluetooth \
16                  --enable-tools \
17                  --with-wbxml"
18
19 CFLAGS += "-I${STAGING_INCDIR}/libsoup-2.2"
20
21 do_configure_append() {
22         sed -i s:-I/usr/include/:-I/foo/:g Makefile
23         sed -i s:-I/usr/include/:-I/foo/:g */Makefile
24         sed -i s:-I/usr/include/:-I/foo/:g */*/Makefile
25 }
26
27 do_stage() {
28         autotools_stage_all
29 }
30
31 PACKAGES += "${PN}-tools"
32
33 FILES_${PN}-tools = "${bindir}"
34 FILES_${PN} = "${libdir}/*.so.*"
35