surpport seeking the recorded video
[vuplus_openembedded] / recipes / opensync / libsyncml_0.4.0.bb
1 DESCRIPTION = "Libsyncml is a implementation of the SyncML protocol."
2 HOMEPAGE = "http://libsyncml.opensync.org/"
3 LICENSE = "LGPL"
4
5 DEPENDS = "sed-native wbxml2 libsoup libxml2 bluez-libs openobex"
6
7 SRC_URI = "http://ewi546.ewi.utwente.nl/OE/source/${P}.tar.gz"
8
9 inherit autotools pkgconfig
10
11 EXTRA_OECONF = " --enable-http \
12                  --enable-obex \
13                  --enable-bluetooth \
14                  --enable-tools \
15                  --with-wbxml"
16
17 CFLAGS += "-I${STAGING_INCDIR}/libsoup-2.2"
18
19 do_configure_append() {
20         sed -i s:-I/usr/include/:-I/foo/:g Makefile
21         sed -i s:-I/usr/include/:-I/foo/:g */Makefile
22         sed -i s:-I/usr/include/:-I/foo/:g */*/Makefile
23 }
24
25
26 PACKAGES += "${PN}-tools"
27
28 FILES_${PN}-tools = "${bindir}"
29 FILES_${PN} = "${libdir}/*.so.*"
30
31
32
33
34