[hbbtv/youtubetv] Fixed hanup bug and segmentation fault on 3rd-party images.
[vuplus_openembedded] / recipes / numptyphysics / numptyphysics_svn.bb
1 DESCRIPTION = "Numpty Physics is a drawing puzzle game in the spirit (and style?) \
2 of Crayon Physics using the same excellent Box2D engine."
3 DEPENDS = "virtual/libsdl libsdl-image libpng"
4 RDEPENDS += "libpng"
5 LICENSE = "GPL"
6 HOMEPAGE = "http://numptyphysics.garage.maemo.org/"
7 SECTION = "x11/games"
8 PV = "0.2+svnr${SRCPV}"
9 PR = "r1"
10
11 inherit autotools
12
13 SRC_URI = "\
14 # Maemo garage is sadly only available with https. Can make you trouble while fetching without accepting the certificate.
15   svn://garage.maemo.org/svn/${PN};module=trunk;proto=https \
16   http://wwwpub.zih.tu-dresden.de/~mkluge/numptyphysics_setup.tgz \
17   file://replay_off.patch;patch=1;pnum=0 \
18   file://next.png \
19   file://keyb.patch;patch=1;pnum=0 \
20   file://keyb.png \
21   file://faster.patch;patch=1;pnum=0 \
22   file://numptyphysics.desktop \
23 "
24 S = "${WORKDIR}/trunk"
25
26 EXTRA_S = "${WORKDIR}/local/packages/numptyphysics"
27
28 do_configure_append() {
29   mv ../next.png data
30   mv ../keyb.png data
31 }
32
33 do_install_append() {
34         install -d ${D}${datadir}/numptyphysics
35         install -d ${D}${datadir}/pixmaps
36         install -d ${D}${datadir}/applications
37         install -m 0644 ${EXTRA_S}/star.png ${D}${datadir}/pixmaps
38         install -m 0644 ../numptyphysics.desktop ${D}/${datadir}/applications
39         cp -a ${EXTRA_S}/data/* data/keyb.png ${D}/${datadir}/numptyphysics/
40 }
41
42 FILES_${PN} += "${datadir}"