surpport seeking the recorded video
[vuplus_openembedded] / recipes / ntpclient / ntpclient_2003_194.bb
1 DESCRIPTION = "NTP (RFC-1305) client for unix-alike computers"
2 HOMEPAGE = "http://doolittle.icarus.com/ntpclient"
3 AUTHOR = "Larry Doolittle <larry@doolittle.boa.org>"
4 RDEPENDS = "busybox"
5 SECTION = "admin"
6 LICENSE = "GPLv2"
7 PR = "r1"
8 # The ntpclient package uses version numbers that include an underscore :(
9 PV = "2003_194"
10 # ntpclient unpacks into a directory that doesn't include version info :(
11 S = "${WORKDIR}/${PN}"
12
13 SRC_URI = "http://doolittle.icarus.com/ntpclient/ntpclient_${PV}.tar.gz \
14            file://init"
15
16 INITSCRIPT_NAME = "ntpclient"
17 INITSCRIPT_PARAMS = "defaults 65"
18 inherit update-rc.d
19
20 do_compile() {
21     oe_runmake ntpclient
22     oe_runmake adjtimex
23 }
24
25 do_install () {
26     # Install the binary and tools
27     install -D -m 0755 ${S}/ntpclient ${D}${base_sbindir}/ntpclient
28     install -D -m 0755 ${S}/adjtimex ${D}${base_sbindir}/adjtimex
29     install -D -m 0755 ${S}/rate.awk ${D}${sbindir}/ntpclient-drift-rate.awk
30     install -D -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/ntpclient
31 }
32