surpport seeking the recorded video
[vuplus_openembedded] / recipes / nfs-utils / nfs-utils_1.0.6.bb
1 DESCRIPTION = "userspace utilities for kernel nfs"
2 PRIORITY = "optional"
3 SECTION = "console/network"
4 LICENSE = "GPL"
5 PR = "r13"
6
7 SRC_URI = "${SOURCEFORGE_MIRROR}/nfs/nfs-utils-${PV}.tar.gz \
8         file://acinclude-lossage.patch;patch=1 \
9         file://rpcgen-lossage.patch;patch=1 \
10         file://stat-include.patch;patch=1 \
11         file://nfs-utils-1.0.6-uclibc.patch;patch=1 \
12         file://kernel-2.6.18+.patch;patch=1 \
13         file://uclibc_bzero_fix.patch;patch=1 \
14         file://nfsserver \
15         file://forgotten-defines"
16
17 S = "${WORKDIR}/nfs-utils-${PV}/"
18
19 PARALLEL_MAKE = ""
20
21 # Only kernel-module-nfsd is required here (but can be built-in)  - the nfsd module will
22 # pull in the remainder of the dependencies.
23 RDEPENDS = "portmap"
24 RRECOMMENDS = "kernel-module-nfsd"
25
26 INITSCRIPT_NAME = "nfsserver"
27 # The server has no dependencies at the user run levels, so just put
28 # it in at the default levels.  It must be terminated before the network
29 # in the shutdown levels, but that works fine.
30 INITSCRIPT_PARAMS = "defaults"
31
32 inherit autotools update-rc.d
33
34 EXTRA_OECONF = "--with-statduser=nobody \
35                 --enable-nfsv3 \
36                 --with-statedir=/var/lib/nfs"
37
38 do_compile() {
39         # UGLY HACK ALERT
40         cat ${WORKDIR}/forgotten-defines >> ${S}/support/include/config.h
41         oe_runmake 'BUILD=1'
42 }
43
44 INHIBIT_AUTO_STAGE = "1"
45
46 do_install() {
47         install -d ${D}${sysconfdir}/init.d
48         install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver
49
50         install -d ${D}${sbindir}
51         install -m 0755 ${S}/utils/exportfs/exportfs ${D}${sbindir}/exportfs
52         install -m 0755 ${S}/utils/lockd/lockd ${D}${sbindir}/lockd
53         install -m 0755 ${S}/utils/mountd/mountd ${D}${sbindir}/mountd
54         install -m 0755 ${S}/utils/nfsd/nfsd ${D}${sbindir}/nfsd
55         install -m 0755 ${S}/utils/nfsstat/nfsstat ${D}${sbindir}/nfsstat
56         install -m 0755 ${S}/utils/nhfsstone/nhfsgraph ${D}${sbindir}/nhfsgraph
57         install -m 0755 ${S}/utils/nhfsstone/nhfsnums ${D}${sbindir}/nhfsnums
58         install -m 0755 ${S}/utils/nhfsstone/nhfsrun ${D}${sbindir}/nhfsrun
59         install -m 0755 ${S}/utils/nhfsstone/nhfsstone ${D}${sbindir}/nhfsstone
60         install -m 0755 ${S}/utils/rquotad/rquotad ${D}${sbindir}/rquotad
61         install -m 0755 ${S}/utils/showmount/showmount ${D}${sbindir}/showmount
62         install -m 0755 ${S}/utils/statd/statd ${D}${sbindir}/statd
63
64         install -d ${D}${mandir}/man8
65         install -m 0644 ${S}/utils/exportfs/exportfs.man ${D}${mandir}/man8/exportfs.8
66         install -m 0644 ${S}/utils/lockd/lockd.man ${D}${mandir}/man8/lockd.8
67         install -m 0644 ${S}/utils/mountd/mountd.man ${D}${mandir}/man8/mountd.8
68         install -m 0644 ${S}/utils/nfsd/nfsd.man ${D}${mandir}/man8/nfsd.8
69         install -m 0644 ${S}/utils/nfsstat/nfsstat.man ${D}${mandir}/man8/nfsstat.8
70         install -m 0644 ${S}/utils/nhfsstone/nhfsgraph.man ${D}${mandir}/man8/nhfsgraph.8
71         install -m 0644 ${S}/utils/nhfsstone/nhfsnums.man ${D}${mandir}/man8/nhfsnums.8
72         install -m 0644 ${S}/utils/nhfsstone/nhfsrun.man ${D}${mandir}/man8/nhfsrun.8
73         install -m 0644 ${S}/utils/nhfsstone/nhfsstone.man ${D}${mandir}/man8/nhfsstone.8
74         install -m 0644 ${S}/utils/rquotad/rquotad.man ${D}${mandir}/man8/rquotad.8
75         install -m 0644 ${S}/utils/showmount/showmount.man ${D}${mandir}/man8/showmount.8
76         install -m 0644 ${S}/utils/statd/statd.man ${D}${mandir}/man8/statd.8
77 }