surpport seeking the recorded video
[vuplus_openembedded] / recipes / networkmanager / network-manager-applet_0.7.1.bb
1 DESCRIPTION = "GTK+ applet for NetworkManager" 
2 LICENSE = "GPL"
3 DEPENDS = "policykit-gnome libnotify networkmanager dbus-glib libglade gconf gnome-keyring"
4 RDEPENDS = "networkmanager"
5
6 PR = "r2"
7
8 inherit gnome
9
10 SRC_URI += "file://nm-applet.conf"
11
12 do_configure_append() {
13         rm config.log
14         # Sigh... --enable-compile-warnings=no doesn't actually turn off -Werror
15         for i in $(find ${S} -name "Makefile") ; do
16             sed -i -e s:-Werror::g $i
17         done
18 }
19
20 # Hack around dbus a_console problems
21 do_install_append() {
22         install -m 0644 ${WORKDIR}/nm-applet.conf ${D}${sysconfdir}/dbus-1/system.d/
23 }
24
25 FILES_${PN} += "${datadir}/nm-applet/ \
26         ${datadir}/gnome-vpn-properties/ \
27         ${datadir}/gnome/autostart/ \
28         "