surpport seeking the recorded video
[vuplus_openembedded] / recipes / netsurf / libnsgif_0.0.1.bb
1 DESCRIPTION = "Libnsgif is a decoding library for the GIF image file format"
2 HOMEPAGE = "http://www.netsurf-browser.org/projects/libnsgif/"
3 SECTION = "libs"
4 PRIORITY = "optional"
5 LICENSE = "MIT"
6
7 SRC_URI = "http://www.netsurf-browser.org/projects/releases/libnsgif-${PV}-src.tar.gz \
8            file://libnsgif-strict-aliasing.patch;patch=1"
9
10 PR = "r1"
11
12 inherit pkgconfig
13
14 EXTRA_OEMAKE = "CURDIR=${S} DESTDIR=${D} PREFIX=${prefix} BUILDDIR=build-OE"
15
16 # NOTE: we're using default buildmode here, which results in building only
17 # static libraries (.a) Not a problem as libnsbmp is only used by Netsurf
18 # at the moment
19
20 do_stage() {
21         oe_libinstall -a -C build-OE/ libnsgif ${STAGING_LIBDIR}
22         install -m 0644 include/*.h ${STAGING_INCDIR}/
23 }
24
25 do_install() {
26         oe_runmake install
27 }