surpport seeking the recorded video
[vuplus_openembedded] / recipes / net-snmp / net-snmp_5.4.2.1.bb
1 require net-snmp.inc
2 PR = "${INC_PR}.0"
3
4 SRC_URI = "${SOURCEFORGE_MIRROR}/net-snmp/net-snmp-${PV}.tar.gz \
5         file://configure-tail.patch;patch=1 \
6         file://init \
7         file://snmpd.conf \
8         file://snmptrapd.conf"
9
10 EXTRA_OECONF = "--enable-shared --disable-manuals --with-defaults \
11                 --disable-embedded-perl --with-perl-modules=no"
12 EXTRA_OEMAKE = "INSTALL_PREFIX=${D}"
13
14 do_configure_prepend() {
15         gnu-configize -f
16         # We better change sources and re-autoconf here, but
17         # required autoconf is too new for us.
18         sed -e '/echo.*\".*\\\\.*\"/s/echo/echo -e/g' \
19             -e 's/tail -1/tail -n 1/g'                \
20             -i configure
21
22         #The tarball for v5.4.2.1 is missing config.sub
23         cp ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}
24 }
25
26 PARALLEL_MAKE = ""
27 CCACHE = ""