surpport seeking the recorded video
[vuplus_openembedded] / recipes / mtd / mtd-utils-tests_1.2.0+git.bb
1 require mtd-utils_1.2.0+git.bb
2
3 # this can probably be integrated into the main mtd-utils package
4 # but I did not want to risk breakage -- but would be glad to 
5 # integrate them if that is best -- cbrake
6
7 SRC_URI = "git://git.infradead.org/mtd-utils.git;protocol=git;tag=${TAG}"
8
9 PR = "r1"
10
11 S = "${WORKDIR}/git/tests/fs-tests"
12
13 FILES_${PN} = "${datadir}/mtd-utils"
14
15 do_compile () {
16         make || die "Make failed"
17 }
18
19 do_stage () {
20 }
21
22 INHIBIT_PACKAGE_STRIP = "1"
23
24 mtd_utils_tests = " \
25         help_all.sh \
26         run_all.sh \
27         integrity/integck \
28         simple/ftrunc \
29         simple/test_1 \ 
30         simple/test_2 \ 
31         stress/stress00.sh \
32         stress/stress01.sh \
33         stress/atoms/fwrite00 \
34         stress/atoms/gcd_hupper \
35         stress/atoms/pdfrun \
36         stress/atoms/rmdir00 \
37         stress/atoms/rndrm00 \
38         stress/atoms/rndrm99 \
39         stress/atoms/rndwrite00 \
40         stress/atoms/stress_1 \
41         stress/atoms/stress_2 \
42         stress/atoms/stress_3 \
43         utils/free_space \
44         utils/fstest_monitor \
45         "
46         
47 do_install () {
48         install -d ${D}${datadir}/mtd-utils/tests
49         install -d ${D}${datadir}/mtd-utils/tests/integrity  
50         install -d ${D}${datadir}/mtd-utils/tests/simple  
51         install -d ${D}${datadir}/mtd-utils/tests/stress
52         install -d ${D}${datadir}/mtd-utils/tests/stress/atoms
53         install -d ${D}${datadir}/mtd-utils/tests/utils
54         for app in ${mtd_utils_tests}; do
55                 install -m 0755 $app ${D}${datadir}/mtd-utils/tests/$app
56         done
57 }
58
59