surpport seeking the recorded video
[vuplus_openembedded] / recipes / monotone / monotone-6_0.33.bb
1 DESCRIPTION = "Monotone is a distributed Source Control System"
2 HOMEPAGE = "http://www.monotone.ca/"
3 SECTION = "devel"
4 PRIORITY = "optional"
5 LICENSE = "MIT"
6 DEPENDS = "boost"
7
8 PROVIDES = "monotone"
9 RPROVIDES = "monotone"
10
11 S = "${WORKDIR}/monotone-${PV}"
12 # no cross compile support - it tries to run the test program even with
13 # --enable_ipv6=yes
14 EXTRA_OECONF = "--disable-ipv6 \
15                 --disable-dependency-tracking \
16                 --disable-rpath \
17                 --disable-nls \
18                 --with-gnu-ld \
19                 --with-bundled-lua --with-bundled-sqlite"
20
21 inherit autotools
22
23 # Release 0.22 reveals bugs in g++ for thumb (g++ generates
24 # relocations which the linker cannot represent)
25 #FIXME: remove the following
26 ARM_INSTRUCTION_SET = "arm"
27
28 PR = "r1"
29
30 SRC_URI = "http://monotone.ca/downloads/${PV}/monotone-${PV}.tar.gz \
31            file://txt2c-cross-post-0.22.patch;patch=1 \
32            file://uclibc.database.hh.stdarg.patch;patch=1 \
33            file://configure.ac-no-sync-with-stdio-0.31.patch;patch=1 \
34           "
35 do_compile_append() {
36         touch testsuite
37 }
38
39 # This makes the testsuite as a package and renames the monotone executable
40 # to include the netsync suffix.
41 do_install_append() {
42         install -d ${D}${tsd}
43         install -c -m 755 testsuite ${D}${tsd}/testsuite
44         cp -pPR tests ${D}${tsd}/tests
45         rm ${D}/home/monotone/monotone-6/tests/diff_a_binary_file/binary
46 }
47
48 PACKAGES = "${PN}-dbg ${PN} ${PN}-doc ${PN}-testsuite"
49 tsd = "/home/monotone/${PN}"
50 FILES_${PN}-testsuite = "${tsd}/testsuite ${tsd}/tests"
51 RDEPENDS_${PN}-testsuite += "bash sed grep cvs patch perl perl-modules"
52