surpport seeking the recorded video
[vuplus_openembedded] / recipes / mokoeightball / mokoeightball_svn.bb
1 DESCRIPTION = "Magic 8 Ball"
2 HOMEPAGE = "http://www.opkg.org/package_35.html"
3 AUTHOR = "Jakob Westhoff"
4 LICENSE = "GPLv2"
5 SECTION = "x11/game"
6 SRCREV = "45"
7 PV = "0.2+svnr${SRCPV}"
8 PR = "r0"
9 S = "${WORKDIR}/"
10 FILES_${PN} += /usr/share/moko_eightball/Accelerometer/__init__.py
11 FILES_${PN} += /usr/share/moko_eightball/themes/eightball.edj
12
13 SRC_URI = "svn://svn.pureenergy.cc/moko_eightball;module=.;proto=svn \
14            file://files/fixpath.patch;patch=1"
15
16 do_compile() {
17         cd python/src/data/themes
18         ./maketheme.sh
19 }
20
21 do_install() {
22         cd python
23         install -d 0755 ${D}/usr/share/moko_eightball
24         install -d 0755 ${D}/usr/share/moko_eightball/Accelerometer
25         install -d 0755 ${D}/usr/share/moko_eightball/themes
26         install -d 0755 ${D}/usr/share/applications
27         install -d 0755 ${D}/usr/share/pixmaps
28         install -d 0755 ${D}/usr/bin
29         install -m 0755 src/eightball.py ${D}/usr/bin/eightball
30         install -m 0644 src/Accelerometer/__init__.py ${D}/usr/share/moko_eightball/Accelerometer/
31         install -m 0644 src/data/themes/eightball.edj ${D}/usr/share/moko_eightball/themes/eightball.edj
32         install -m 0644 ipk/usr/share/applications/eightball.desktop ${D}/usr/share/applications/eightball.desktop
33         install -m 0644 ipk/usr/share/pixmaps/eightball.png ${D}/usr/share/pixmaps/eightball.png
34 }