gtkmathview: fix build for gcc44
[vuplus_openembedded] / recipes / mml-widget / gtkmathview_0.8.0.bb
1 LICENSE = "GPL"
2 HOMEPAGE = "http://helm.cs.unibo.it/mml-widget/"
3 DEPENDS = "t1lib gtk+ popt libxslt libxml2"
4
5 PR = "r1"
6
7 SRC_URI = "http://helm.cs.unibo.it/mml-widget/sources/${P}.tar.gz \
8            file://mathview-gcc43x.diff;patch=1 \
9           "
10
11 inherit autotools 
12 AUTOTOOLS_STAGE_PKGCONFIG = 1
13
14 EXTRA_OECONF = "--disable-binreloc"
15
16 do_configure_prepend() {
17         sed -i -e s:AM_BINRELOC::g ${S}/configure.ac
18 }
19
20 do_stage() {
21         autotools_stage_all
22         for i in ${PKG_CONFIG_DIR}/*math*.pc ; do
23                 sed -i -e s:${STAGING_INCDIR}:'${libdir}':g $i
24         done    
25 }
26