surpport seeking the recorded video
[vuplus_openembedded] / recipes / minipredict / dictionary_en-GB.bb
1 inherit update-alternatives
2
3 DESCRIPTION = "Dictionary file for libdictionary"
4 DEPENDS = "zip-native perl-native"
5 SECTION = "gpe"
6 PRIORITY = "optional"
7
8 SRC_URI = "http://ftp.services.openoffice.org/pub/OpenOffice.org/contrib/dictionaries/en_GB.zip"
9
10 ALTERNATIVE_NAME = "dictionary"
11 ALTERNATIVE_LINK = "${datadir}/dictionary/dictionary"
12 ALTERNATIVE_PATH = "${datadir}/dictionary/en_GB"
13 ALTERNATIVE_PRIORITY = "50"
14
15 do_compile() {
16         perl -ne ' s,/.*,,; next if ( /[.1-9]/ || /^.{0,1}$/ ); print;' ${WORKDIR}/en_GB.dic | sort > en_GB
17 }
18
19 FILES_${PN} = "${datadir}/dictionary"
20
21 do_install() {
22         install -d ${D}/${datadir}/dictionary
23         install ${S}/en_GB ${D}/${datadir}/dictionary/
24 }
25