[hbbtv/youtubetv] Fixed hanup bug and segmentation fault on 3rd-party images.
[vuplus_openembedded] / recipes / matchbox2 / matchbox-wm-2_svn.bb
1 DEPENDS = "gtk+ startup-notification dbus dbus-glib"
2 PV = "0.1.0+svnr${SRCPV}"
3 PR = "r0"
4
5 SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=matchbox-window-manager-2;proto=http \
6            file://fix-timeout-handler-free.patch;patch=1 \
7            file://makefile-vars.patch;patch=1;pnum=0 \
8 "
9 S = "${WORKDIR}/matchbox-window-manager-2"
10
11 inherit autotools pkgconfig
12
13 # FIXME: --enable-glib-main-loop causes hard grab-freeze
14 EXTRA_OECONF = "--with-gtk --with-pango --enable-matchbox-remote --enable-png-theme --enable-maemo-manager"
15
16 do_install_append() {
17         mv ${D}${bindir}/matchbox-remote ${D}${bindir}/matchbox-remote-2
18         # Without libmatchbox there are no includes and no libraries, just empty directories:
19         rm -r ${D}${includedir} ${D}${libdir}
20 }
21
22 FILES_${PN} += "${datadir}/themes/*"