[hbbtv/youtubetv] Fixed hanup bug and segmentation fault on 3rd-party images.
[vuplus_openembedded] / recipes / matchbox2 / matchbox-panel-2_svn.bb
1 DESCRIPTION = "matchbox-panel-2 is a lightweight dock (system tray) application based on Gtk+"
2 LICENSE = "GPLv2"
3 SECTION = "x11/panels"
4 DEPENDS = "gtk+ startup-notification dbus dbus-glib matchbox-panel-2-icon-themes"
5 DEPENDS += " ${@base_contains("MACHINE_FEATURES", "acpi", "libacpi", "",d)}"
6 DEPENDS += " ${@base_contains("MACHINE_FEATURES", "apm", "apmd", "",d)}"
7 RDEPENDS_${PN} = "matchbox-panel-2-icon-theme"
8 PACKAGE_ARCH = "${MACHINE_ARCH}"
9 PV = "2.0+svnr${SRCPV}"
10 PR = "r1"
11
12 inherit autotools_stage pkgconfig
13
14 SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http \
15            file://scaling-image-double-free.patch;patch=1;pnum=0 \
16            file://startup-invalid-access.patch;patch=1;pnum=0 \
17            file://startup-shown-uninitialized.patch;patch=1;pnum=0 \
18            file://themeable-icons.patch;patch=1;pnum=0 \
19 "
20 S = "${WORKDIR}/${PN}"
21
22 TARGET_CFLAGS += "-Wno-error"
23
24 EXTRA_OECONF = "--disable-static --program-transform-name='s/$/-2/'"
25 EXTRA_OECONF += " ${@base_contains("MACHINE_FEATURES", "acpi", "--with-battery=acpi", "",d)}"
26 EXTRA_OECONF += " ${@base_contains("MACHINE_FEATURES", "apm", "--with-battery=apm", "",d)}"
27
28 do_install_append() {
29         rm ${D}${libdir}/matchbox-panel/lib*.*a
30 }
31
32 FILES_${PN} += "${libdir}/matchbox-panel/*.so"
33 FILES_${PN}-dbg += "${libdir}/matchbox-panel/.debug"