surpport seeking the recorded video
[vuplus_openembedded] / recipes / matchbox-wm / matchbox-wm_svn.bb
1 require matchbox-wm.inc
2
3 DEPENDS = "libmatchbox virtual/libx11 libxext libxcomposite libxfixes libxdamage libxrender startup-notification expat gconf "
4 RDEPENDS = ""
5 PV = "1.1+svn${SRCDATE}"
6 PR = "r4"
7 DEFAULT_PREFERENCE = "-1"
8
9 SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=matchbox-window-manager;proto=http \
10            file://kbdconfig"
11
12 S = "${WORKDIR}/matchbox-window-manager"
13
14 inherit autotools pkgconfig update-alternatives
15
16 ALTERNATIVE_NAME = "x-window-manager"
17 ALTERNATIVE_LINK = "${bindir}/x-window-manager"
18 ALTERNATIVE_PATH = "${bindir}/matchbox-session"
19 ALTERNATIVE_PRIORITY = "10"
20
21 FILES_${PN} = "${bindir}/* \
22                ${datadir}/matchbox \
23                ${sysconfdir}/matchbox \
24                ${datadir}/themes/blondie/matchbox \
25                ${datadir}/themes/Default/matchbox \
26                ${datadir}/themes/MBOpus/matchbox"
27
28 EXTRA_OECONF = "--enable-composite --enable-startup-notification --disable-xrm"
29
30 do_install_prepend() {
31         install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig
32 }
33