surpport seeking the recorded video
[vuplus_openembedded] / recipes / mamona / gcc-noemu_4.1.1.bb
1 PR = "r14"
2 DESCRIPTION = "The GNU cc and gcc C compilers."
3 HOMEPAGE = "http://www.gnu.org/software/gcc/"
4 SECTION = "devel"
5 LICENSE = "GPL"
6
7 RCONFLICTS = "gcc"
8 RREPLACES = "gcc"
9
10 inherit autotools gettext
11
12 require gcc-package-noemu.inc
13
14 SRC_URI = "http://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.1/gcc-4.1.1.tar.bz2 \
15         file://100-uclibc-conf.patch;patch=1 \
16         file://110-arm-eabi.patch;patch=1 \
17         file://200-uclibc-locale.patch;patch=1 \
18         file://300-libstdc++-pic.patch;patch=1 \
19         file://301-missing-execinfo_h.patch;patch=1 \
20         file://302-c99-snprintf.patch;patch=1 \
21         file://303-c99-complex-ugly-hack.patch;patch=1 \
22         file://304-index_macro.patch;patch=1 \
23         file://602-sdk-libstdc++-includes.patch;patch=1 \
24         file://740-sh-pr24836.patch;patch=1 \
25         file://800-arm-bigendian.patch;patch=1 \
26         file://801-arm-bigendian-eabi.patch;patch=1 \
27         file://arm-nolibfloat.patch;patch=1 \
28         file://arm-softfloat.patch;patch=1 \
29         file://gcc41-configure.in.patch;patch=1 \
30         file://arm-thumb.patch;patch=1 \
31         file://arm-thumb-cache.patch;patch=1 \
32         file://ldflags.patch;patch=1 \
33         file://cse.patch;patch=1 \
34         file://zecke-xgcc-cpp.patch;patch=1 \
35         file://unbreak-armv4t.patch;patch=1 \
36         file://fix-ICE-in-arm_unwind_emit_set.diff;patch=1 \
37         file://gcc-4.1.1-pr13685-1.patch;patch=1 \
38         file://gcc-ignore-cache.patch;patch=1 \
39         "
40
41 SRC_URI_append_sh3  = " file://sh3-installfix-fixheaders.patch;patch=1 "
42
43 #This is a dirty hack to get gcc 4.1.1 to compile for glibc AND uclibc on ppc
44 #the patch that is need it to get gcc support soft-floats with glibc, makes gcc fail with uclibc
45 SRC_URI_append_linux = " file://ppc-gcc-41-20060515.patch;patch=1 \
46                          file://ppc-sfp-long-double-gcc411-7.patch;patch=1 "
47
48
49 #Set the fortran bits
50 # 'fortran' or '', not 'f77' like gcc3 had
51 FORTRAN = ""
52 HAS_GFORTRAN = "no"
53 HAS_G2C = "no"
54
55 #Set the java bits
56 JAVA_arm = ""
57 JAVA = ""
58
59 LANGUAGES = "c,c++${FORTRAN}${JAVA}"
60 require recipes/gcc/gcc-${PV}.inc
61
62 EXTRA_OECONF += "--disable-libspp --with-slibdir=\"/lib\""
63
64 EXTRA_OEMAKE += "LDFLAGS=\"-static\" build_tooldir=\"${STAGING_DIR}/${TARGET_SYS}\""
65
66 HOST_SYS = ${BUILD_SYS}
67
68 CONFIG_SITE=""
69
70 do_configure () {
71     export CPP="gcc -E"
72     export CC=gcc
73     export AS=as
74     export LD=ld
75     export CXX=g++ 
76     export AR=ar
77     export OBJCOPY=objcopy 
78     export OBJDUMP=objdump 
79     export RANLIB=ranlib 
80     export NM=nm 
81     export STRIP=strip
82     export CFLAGS="-fexpensive-optimizations -fomit-frame-pointer -frename-registers -Os"
83     export CXXFLAGS="-fexpensive-optimizations -fomit-frame-pointer -frename-registers -Os -fpermissive -fvisibility-inlines-hidden"
84     oe_runconf
85 }