surpport seeking the recorded video
[vuplus_openembedded] / recipes / mamona / binutils-noemu_2.17.50.0.5.bb
1 require ../binutils/binutils.inc
2
3 PR = "r1"
4
5 RCONFLICTS = "binutils"
6 RREPLACES = "binutils"
7
8 SRC_URI = \
9     "${KERNELORG_MIRROR}/pub/linux/devel/binutils/binutils-${PV}.tar.bz2 \
10      file://binutils-2.16.91.0.6-objcopy-rename-errorcode.patch;patch=1 \
11      file://binutils-uclibc-100-uclibc-conf.patch;patch=1 \
12      file://binutils-configure-texinfo-version.patch;patch=1 \
13      file://110-arm-eabi-conf.patch;patch=1 \
14      file://binutils-uclibc-300-001_ld_makefile_patch.patch;patch=1 \
15      file://binutils-uclibc-300-006_better_file_error.patch;patch=1 \
16      file://binutils-uclibc-300-012_check_ldrunpath_length.patch;patch=1 \
17      "
18
19 EXTRA_OECONF = "--with-sysroot=${CROSS_DIR}/${TARGET_SYS} \
20                 --program-prefix=${TARGET_PREFIX} --disable-shared"
21
22 HOST_SYS = "${BUILD_SYS}"
23
24 do_configure () {
25     CC=gcc AS=as LD=ld CXX=g++ AR=ar OBJCOPY=objcopy OBJDUMP=objdump RANLIB=ranlib NM=nm STRIP=strip oe_runconf
26 }
27
28 do_compile() {
29     make configure-host
30     make LDFLAGS=\"-all-static\"
31 }
32
33 do_stage() {
34     :
35 }