surpport seeking the recorded video
[vuplus_openembedded] / recipes / lsh / lsh_1.5.5.bb
1 LICENSE = "GPL"
2 SECTION = "console/network"
3 DESCRIPTION = "lsh is a GNU GPL-licensed implementation of the SSH \
4 (version 2) protocol. It includes a server, a client, and some \
5 utility programs."
6 DEPENDS = "zlib gmp liboop"
7
8 SRC_URI = "http://www.lysator.liu.se/~nisse/archive/lsh-${PV}.tar.gz"
9 S = "${WORKDIR}/lsh-${PV}"
10
11 inherit autotools
12 configopts = "  --enable-debug-alloc    Enable memory allocation sanity checks \
13                 --enable-debug-trace    Enable tracing support \
14                 --enable-gcov           Instrument for gcov (requires a modern gcc) \
15                 --without-pty           Disable pty support \
16                 --disable-srp           Disable the (experimental) support for SRP \
17                 --disable-kerberos      Don't support kerberos \
18                 --disable-pam           Don't support PAM \
19                 --disable-datafellows-workarounds \
20                 --enable-initgroups-workaround \
21                 --disable-tcp-forward   Disable tcp forwarding \
22                 --disable-x11-forward   Disable x11 forwarding (proxy only) \
23                 --disable-agent-forward Disable auth-agent forwarding (proxy only) \
24                 --disable-ipv6          Disable IPv6 support \
25                 --disable-utmp          Disable utmp and wtmp support \
26                 --without-zlib          Don't use zlib compression \
27                 --with-tcpwrappers      Use tcp-wrappers for filtering connections \
28                 --with-sshd1=PROGRAM support fallback to SSH1 daemon \
29                 --with-scheme=PROGRAM Use a particular scheme implementation \
30                 --without-system-argp   Don't use the system's argp \
31                 --with-include-path     A colon-separated list of directories to search for \
32                 --with-lib-path         A colon-separated list of directories to search for \
33                 --with-x                use the X Window System"
34 EXTRA_OECONF = "--disable-srp --disable-kerberos --disable-pam \
35                 --without-x"