[hbbtv/youtubetv] Fixed hanup bug and segmentation fault on 3rd-party images.
[vuplus_openembedded] / recipes / linux / linux_2.6.32.bb
1 require linux.inc
2
3 PR = "r5"
4
5 S = "${WORKDIR}/linux-${PV}"
6
7 # Mark archs/machines that this kernel supports
8 DEFAULT_PREFERENCE = "-1"
9 DEFAULT_PREFERENCE_ion = "1"
10 DEFAULT_PREFERENCE_simone = "1"
11 DEFAULT_PREFERENCE_eee701 = "1"
12 DEFAULT_PREFERENCE_at91sam9g45ek = "1"
13
14 DEFAULT_PREFERENCE_akita = "-1"
15 DEFAULT_PREFERENCE_c7x0 = "-1"
16 DEFAULT_PREFERENCE_collie = "-1"
17 DEFAULT_PREFERENCE_poodle = "-1"
18 DEFAULT_PREFERENCE_spitz = "-1"
19 DEFAULT_PREFERENCE_tosa = "-1"
20 DEFAULT_PREFERENCE_ben-nanonote = "-1"
21 DEFAULT_PREFERENCE_jornada6xx = "-1"
22 DEFAULT_PREFERENCE_jornada7xx = "-1"
23
24 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2;name=kernel \
25            ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${PV}.5.bz2;patch=1 \
26            file://defconfig"
27
28 SRC_URI[kernel.md5sum] = "260551284ac224c3a43c4adac7df4879"
29 SRC_URI[kernel.sha256sum] = "5099786d80b8407d98a619df00209c2353517f22d804fdd9533b362adcb4504e"
30
31 SRC_URI_append_at91sam9g45ek = " \
32         file://at91/linux-2.6.32-001-configurable-nand-partitions.patch;patch=1 \
33         file://at91/linux-2.6.32-002-sam9g20-proper-reset.patch;patch=1 \
34         "
35
36
37 # part of 2.6.24.7 patchset from Sim.One project
38 # other patches needs work
39 SRC_URI_append_simone = " \
40                         file://ep93xx/edb9301-fix-machine-id.patch;patch=1 \
41                         file://ep93xx/simone-board-def.patch;patch=1 \
42                         file://ep93xx/ep93xx-regs.patch;patch=1 \
43                         file://ep93xx/ep93xx-i2c.patch;patch=1 \
44                         file://ep93xx/ep93xx-touchscreen.patch;patch=1 \
45                         file://ep93xx/ep93xx-spi.patch;patch=1 \
46                         file://ep93xx/ep93xx-cpuinfo.patch;patch=1 "
47
48 # Zaurus family bootloader patches
49 RPSRC = "http://www.rpsys.net/openzaurus/patches/archive"
50 ZAURUSPATCHES = " ${RPSRC}/pxa-linking-bug-r1.patch;patch=1;status=unmergable;name=pxa-linking-bug-r1 "
51 SRC_URI[pxa-linking-bug-r1.md5sum] = "1e2a99787260c3566033e7f41180e2c8"
52 SRC_URI[pxa-linking-bug-r1.sha256sum] = "785d2680022325ad54c1593082dce902f5fee31dae4c1922ba43956b1dcfcd8b"
53
54 # Machine specific patches
55 SRC_URI_append_akita = "${ZAURUSPATCHES}"
56 SRC_URI_append_c7x0 = "${ZAURUSPATCHES}"
57 SRC_URI_append_collie = "${ZAURUSPATCHES}"
58 SRC_URI_append_poodle = "${ZAURUSPATCHES}"
59 SRC_URI_append_spitz = "${ZAURUSPATCHES}"
60 SRC_URI_append_tosa = "${ZAURUSPATCHES}"