[hbbtv/youtubetv] Fixed hanup bug and segmentation fault on 3rd-party images.
[vuplus_openembedded] / recipes / linux / linux-turbostation_2.6.20.2.bb
1 DESCRIPTION = "Linux Kernel for the QNAP TurboStation platform"
2 SECTION = "kernel"
3 LICENSE = "GPL"
4 DEPENDS = "u-boot-utils-native"
5 PR = "r2"
6
7 COMPATIBLE_MACHINE = "turbostation"
8
9 RDEPENDS_kernel-module-zd1211rw += "zd1211-firmware"
10
11 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
12         file://001_r1000.diff;patch=1 \
13         file://linux-2.6.16_arch_ppc_platforms_sandpoint.h;patch=1 \
14         file://002_qnap-pic.diff;patch=1 \
15         file://linux-2.6.16_arch_ppc_syslib_Makefile;patch=1 \
16         file://linux-2.6.16_drivers_mtd_maps_physmap.c;patch=1 \
17         file://linux-2.6.16_arch_ppc_syslib_mpc10x_common.c;patch=1 \
18         file://linux-2.6.16_arch_ppc_platforms_Makefile;patch=1 \
19         file://linux-2.6.16_include_asm-ppc_mpc10x.h;patch=1 \
20         file://linux-2.6.16_arch_ppc_platforms_sandpoint.c;patch=1 \
21         file://defconfig"
22
23 S = "${WORKDIR}/linux-${PV}"
24
25 inherit kernel
26
27 KERNEL_IMAGETYPE = "uImage"
28 KERNEL_OUTPUT = "arch/${ARCH}/boot/images/${KERNEL_IMAGETYPE}"
29 # Override arch. The kernel stuff is in arch/ppc, not arch/powerpc in our case
30 ARCH = ppc
31
32 do_configure() {
33                 install -m 644 ${WORKDIR}/defconfig ${S}/.config
34                 make ARCH=ppc oldconfig
35 }
36
37 #ppc build leaves the kernel in a different place
38 #do_movekernel() {
39 #
40 #}