surpport seeking the recorded video
[vuplus_openembedded] / recipes / linux / linux-rp_2.6.23.bb
1 require linux-rp.inc
2
3 PR = "r36"
4
5 # Handy URLs
6 # git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git;protocol=git;tag=ef7d1b244fa6c94fb76d5f787b8629df64ea4046
7 # ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.18.tar.bz2
8 # ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/testing/linux-2.6.20-rc4.tar.bz2
9 # ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/testing/patch-2.6.18-rc6.bz2;patch=1
10 # ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/snapshots/patch-2.6.18-rc2-git1.bz2;patch=1
11 # ${KERNELORG_MIRROR}/pub/linux/kernel/people/alan/linux-2.6/2.6.10/patch-2.6.10-ac8.gz;patch=1
12 # ${KERNELORG_MIRROR}/pub/linux/kernel/people/akpm/patches/2.6/2.6.14-rc2/2.6.14-rc2-mm1/2.6.14-rc2-mm1.bz2;patch=1
13
14 # Patches submitted upstream are towards top of this list 
15 # Hacks should clearly named and at the bottom
16 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.23.tar.bz2 \
17            file://0001-time-prevent-the-loop-in-timespec_add_ns-from-bei.patch;patch=1 \
18            ${RPSRC}/pxa25x_suspend_fixes-r0.patch;patch=1;status=merged \
19            ${RPSRC}/lzo_jffs2-r3.patch;patch=1;status=merged \
20            ${RPSRC}/lzo_jffs2_lzomode-r1.patch;patch=1;status=merged \
21            ${RPSRC}/spitzkbd_fix-r0.patch;patch=1;status=merged \
22            file://uvesafb-0.1-rc3-2.6.22.patch;patch=1;status=merged \
23            ${RPSRC}/locomo_led_fix-r0.patch;patch=1;status=merged \
24            file://hrw-add-wcf11-to-hostap.patch;patch=1;status=merged \
25            ${RPSRC}/export_atags-r0a.patch;patch=1;status=pending \
26            ${RPSRC}/lzo_crypto-r2.patch;patch=1;status=pending \
27            ${RPSRC}/lzo_jffs2_sysfs-r1.patch;patch=1 \
28            ${RPSRC}/hx2750_base-r29.patch;patch=1 \
29            ${RPSRC}/hx2750_bl-r9.patch;patch=1 \
30            ${RPSRC}/hx2750_pcmcia-r2.patch;patch=1 \
31            ${RPSRC}/hx2750_make.patch;patch=1 \
32            ${RPSRC}/pxa_keys-r7.patch;patch=1 \
33            ${RPSRC}/tsc2101-r16.patch;patch=1 \
34            ${RPSRC}/hx2750_test1-r7.patch;patch=1 \
35            ${RPSRC}/input_power-r9.patch;patch=1 \
36            ${RPSRC}/pxa25x_cpufreq-r2.patch;patch=1 \
37            ${RPSRC}/sharpsl_pm_fixes1-r0.patch;patch=1 \
38            ${RPSRC}/pm_changes-r1.patch;patch=1 \
39            ${RPSRC}/usb_add_epalloc-r3.patch;patch=1 \
40            ${RPSRC}/usb_pxa27x_udc-r6.patch;patch=1 \
41            ${RPSRC}/locomo_kbd_tweak-r1.patch;patch=1 \
42            ${RPSRC}/pxa27x_overlay-r6.patch;patch=1 \
43            ${RPSRC}/w100_extaccel-r2.patch;patch=1 \
44            ${RPSRC}/w100_extmem-r1.patch;patch=1 \
45            ${RPSRC}/poodle_pm-r4.patch;patch=1 \
46            ${RPSRC}/poodle_lcd_hack-r0.patch;patch=1 \
47            ${RPSRC}/poodle_asoc_fix-r1.patch;patch=1 \
48            file://wm8750-treble.patch;patch=1 \
49            file://mtd-module.patch;patch=1 \
50            file://squashfs3.0-2.6.15.patch;patch=1;status=external \
51            ${RPSRC}/logo_oh-r1.patch.bz2;patch=1;status=unmergable \
52            ${RPSRC}/pxa-linking-bug.patch;patch=1;status=unmergable \
53            file://hostap-monitor-mode.patch;patch=1;status=unmergable \
54            file://serial-add-support-for-non-standard-xtals-to-16c950-driver.patch;patch=1;status=unmergable \
55            ${RPSRC}/mmcsd_large_cards-r1.patch;patch=1;status=hack \
56            ${RPSRC}/mmcsd_no_scr_check-r2.patch;patch=1;status=hack \
57            ${RPSRC}/integrator_rgb-r1.patch;patch=1;status=hack \
58            ${RPSRC}/pxa_cf_initorder_hack-r1.patch;patch=1;status=hack \
59            file://pxa-serial-hack.patch;patch=1;status=hack \
60            file://connectplus-remove-ide-HACK.patch;patch=1;status=hack \
61            file://connectplus-prevent-oops-HACK.patch;patch=1;status=hack \
62            file://htcuni.patch;patch=1 \
63            file://binutils-buildid-arm.patch;patch=1 \
64            file://versatile-armv6.patch;patch=1 \
65            file://defconfig-c7x0 \
66            file://defconfig-hx2000 \
67            file://defconfig-collie \
68            file://defconfig-poodle \
69            file://defconfig-akita \
70            file://defconfig-spitz \
71            file://defconfig-qemuarm \
72            file://defconfig-qemux86 \
73            file://defconfig-bootcdx86 \
74            file://defconfig-htcuniversal \
75            file://defconfig-zylonite \
76            file://defconfig-tosa "
77
78 # FIXMEs before made default       
79 # ${RPSRC}/mmcsd_no_scr_check-r1.patch;patch=1;status=hack
80
81 # Add this to enable pm debug code (useful with a serial lead)
82 #  ${RPSRC}/sharpsl_pm_debug-r0.patch;patch=1
83
84 # Disabled until I find the reason this gives issues with cdc_subset
85 #            ${RPSRC}/usb_rndis_tweaks-r0.patch;patch=1 \
86
87 # Is anything out of this still needed? Parts were commited to mainline by rmk (drivers/mfd/)
88 # (Pavel Machek's git tree has updated versions of this?)
89 #  ${JLSRC}/zaurus-lcd-2.6.11.diff.gz;patch=1
90
91 # These patches are extracted from Pavel Machek's git tree
92 # (diff against vanilla kernel)
93 SRC_URI_append_collie = "\
94            ${DOSRC}/collie/mtd-sharp-flash-hack-r0.patch;patch=1 \
95            ${DOSRC}/collie/collie-r0.patch;patch=1 \
96            ${DOSRC}/collie/locomolcd-backlight-r0.patch;patch=1 \
97            ${DOSRC}/collie/ucb1x00-touch-audio-r0.patch;patch=1 \
98            file://collie-mcp-r1.patch;patch=1 \
99            ${DOSRC}/collie/sa1100-udc-r0.patch;patch=1 \
100 #          ${DOSRC}/collie/collie-pm-r1.patch;patch=1 \
101 "
102
103 SRC_URI_append_poodle = "\
104            ${RPSRC}/poodle_serial_vcc-r0.patch;patch=1 \
105 "
106
107 SRC_URI_append_tosa = "\
108            ${CHSRC}/tmio-core-r4.patch;patch=1 \
109            file://tmio-tc6393-r8.patch;patch=1 \
110            file://tmio-nand-r8.patch;patch=1 \
111            ${CHSRC}/tmio-fb-r6.patch;patch=1 \
112            file://tmio-fb-r6-fix-r0.patch;patch=1 \
113            file://tosa-keyboard-r19.patch;patch=1 \
114            ${DOSRC}/tosa-pxaac97-r6.patch;patch=1 \
115            file://tosa-pxaac97-r6-fix-r0.patch;patch=1 \
116            ${DOSRC}/tosa-tmio-r6.patch;patch=1 \
117            file://tosa-power-r18.patch;patch=1 \
118            file://tosa-power-r18-fix-r0.patch;patch=1 \
119            file://tosa-tmio-lcd-r10.patch;patch=1 \
120            file://tosa-tmio-lcd-r10-fix-r0.patch;patch=1 \
121            file://tosa-bluetooth-r8.patch;patch=1 \
122            file://wm97xx-lg13-r0.patch;patch=1 \
123            file://wm97xx-lg13-r0-fix-r0.patch;patch=1 \
124            file://wm9712-suspend-cold-res-r2.patch;patch=1 \
125            file://sharpsl-pm-postresume-r1.patch;patch=1 \
126            file://wm9712-reset-loop-r2.patch;patch=1 \
127            file://tosa-lcdnoise-r1.patch;patch=1 \
128            file://tosa-lcdnoise-r1-fix-r0.patch;patch=1 \
129            file://arm-dma-coherent.patch;patch=1 \
130            file://usb-ohci-hooks-r3.patch;patch=1 \
131            file://tmio-ohci-r9.patch;patch=1 \
132            file://pxa2xx_udc_support_inverse_vbus.patch;patch=1 \
133            file://tosa_udc_use_gpio_vbus.patch;patch=1 \
134            "
135 #          ${DOSRC}/tosa-asoc-r1.patch;patch=1 "
136
137 SRC_URI_append_akita = "\
138            file://sharpsl-rc-r1.patch;patch=1;status=external \
139            "
140
141 SRC_URI_append_spitz = "\
142            file://sharpsl-rc-r1.patch;patch=1;status=external \
143            "
144
145 SRC_URI_append_htcuniversal ="\
146         file://htcuni-acx.patch;patch=1;status=external \
147         "
148
149 SRC_URI_append_zylonite ="\
150         file://arm_pxa_20070923.patch;patch=1 \
151         file://pxa_fb_overlay.patch;patch=1 \
152         file://zylonite-boot.patch;patch=1 \
153         file://zylonite_mtd-r0.patch;patch=1 \
154         file://zylonite_touch-r0.patch;patch=1 \
155         file://zylonite_keypad-r0.patch;patch=1 \
156         "
157
158 S = "${WORKDIR}/linux-2.6.23"