surpport seeking the recorded video
[vuplus_openembedded] / recipes / linux / linux-palmpre_2.6.24.bb
1 require linux.inc
2
3 DESCRIPTION = "Linux kernel for Palm Pre. Original version of Palm, Inc."
4 KERNEL_IMAGETYPE = "uImage"
5
6 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
7            http://palm.cdnetworks.net/opensource/1.1.0/linux-2.6.24-patch.gz;patch=1 \
8            "
9
10 S = "${WORKDIR}/linux-2.6.24"
11
12 # We try to build the identical kernel as Palms here, use their defconfig.
13 do_configure_prepend() {
14         install -m 0644 ${S}/arch/arm/configs/omap_sirloin_3430_defconfig ${WORKDIR}/defconfig
15 }
16
17 # linux.inc overrides LOCAVERSION but we like to stay with the one used originally
18 do_compile_prepend() {
19         sed -i -e '/CONFIG_LOCALVERSION=/d' ${S}/.config
20         echo 'CONFIG_LOCALVERSION="-joplin-3430"' >>${S}/.config
21 }