[hbbtv/youtubetv] Fixed hanup bug and segmentation fault on 3rd-party images.
[vuplus_openembedded] / recipes / linux / linux-mtx-2_2.4.27.bb
1 DESCRIPTION = "Linux kernel for MTX-2 (Surfbox2)"
2 HOMEPAGE = "http://meshcube.org/meshwiki/"
3 LICENSE = "GPL"
4 KV = "${PV}"
5 PR = "r11"
6 inherit module-base kernel
7
8 PROVIDES = "virtual/kernel"
9 RDEPENDS = "mtd-utils"
10
11 SRC_URI += "cvs://cvs:cvs@ftp.linux-mips.org/home/cvs;module=linux;tag=linux_2_4_27 \
12         file://00-mtx-2.diff;patch=1 \
13         file://01-mtd-mtx-2.diff;patch=1 \
14         file://03-mtd-erase-compiler-bug.diff;patch=1 \
15         file://04-mtd-yamonenv-readwrite.diff;patch=1 \
16         file://05-mtx-2-pci-irq.diff;patch=1 \
17         file://06-zboot-2.4.26.patch;patch=1 \
18         file://07-zboot-zimage-flash-bin.diff;patch=1 \
19         file://08-usb-nonpci-2.4.24.patch;patch=1 \
20         file://10-iw-max-spy-32.diff;patch=1 \
21         file://11-mtd-proc-partition-rw.diff;patch=1 \
22         file://12-openswan-2.2.0-nat-t.diff;patch=1 \
23         file://13-openswan-2.2.0.patch;patch=1 \
24         file://16-i2c.patch;patch=1 \
25         file://17-lmsensors.2.8.8.patch;patch=1 \
26         file://18-i2c-au1x00gpio.patch;patch=1 \
27         file://19-kernel-make-depend.diff;patch=1 \
28         file://22-umts.diff;patch=1 \
29         file://27-idsel-cardbus.diff;patch=1 \
30         file://28-surfbox2-idsel.diff;patch=1 \
31         file://29-au1000-pci-config-clear-errors.diff;patch=1 \
32         file://32-usbserial-stalled-hack.diff;patch=1 \
33         file://33-usbserial-bulk_in_size-4096.diff;patch=1 \
34         file://35-sb2-slic.patch;patch=1 \
35         file://36-sb2-lcd.patch;patch=1 \
36         file://37-sb2-sysbtn.patch;patch=1 \
37         file://39-mppe-mpc.patch;patch=1 \
38         file://40-option-hsdpa.patch;patch=1 \
39         file://42-usb-ohci-fixes.patch;patch=1 \
40         file://43-usbserial-27-32-backport.diff;patch=1 \
41         file://44-dbdma-and-au1550_psc.diff;patch=1 \
42         file://45-acm-tty-and-sb2.patch;patch=1 \
43         file://46-otg.patch;patch=1 \
44         file://47-au1000_eth.patch;patch=1 \
45         file://48-pptp.patch;patch=1 \
46         file://49-bash4-configure.patch;patch=1 \
47         file://defconfig-mtx-2"
48
49 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/linux-mtx-2-${PV}"
50
51 S = "${WORKDIR}/linux"
52
53 inherit kernel
54
55 COMPATIBLE_MACHINE = "mtx-2"
56 COMPATIBLE_HOST = "mipsel.*-linux"
57 ARCH = "mips"
58 KERNEL_OUTPUT = "arch/mips/zboot/images/mtx-2.flash.bin"
59 KERNEL_IMAGETYPE = "zImage.flash"
60 KERNEL_IMAGEDEST = "tmp"
61
62 KERNEL_IMAGE_NAME = "kernel-${KV}-${MACHINE}_${BUILDNAME}"
63
64 MTX_KERNEL_NON_PCI_OHCI = "no"
65
66 PACKAGE_ARCH = "mtx-2"
67
68 do_configure_prepend() {
69         install -m 0644 ${WORKDIR}/defconfig-mtx-2 ${S}/.config
70         if [ "x${MTX_KERNEL_NON_PCI_OHCI}" == "xyes" ]; then
71                 echo "CONFIG_USB_NON_PCI_OHCI=y" >> ${S}/.config
72         fi
73 }
74
75 pkg_postinst_kernel() {
76 if test "x$D" != "x"; then
77         exit 1
78 else
79         if test -e /tmp/zImage.flash-${KV}; then
80                 echo "*** flashing kernel ***"
81                 flashcp -v /tmp/zImage.flash-${KV} /dev/mtd/2
82                 echo "*** done. please reboot ***"
83         fi
84 fi
85 }
86
87 FILES_kernel += " /tmp"
88
89 do_deploy() {
90         install -d 0755 ${DEPLOY_DIR_IMAGE}
91         install -m 0644 arch/mips/zboot/images/mtx-2.flash.bin ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGE_NAME}.flash.bin
92         install -m 0644 arch/mips/zboot/images/mtx-2.flash.srec ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGE_NAME}.flash.srec
93         install -m 0644 arch/mips/zboot/images/mtx-2.srec ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGE_NAME}.ram.srec
94 }