surpport seeking the recorded video
[vuplus_openembedded] / recipes / linux / linux-jlime-jornada6xx_2.6.25.bb
1 SECTION = "kernel"
2 DESCRIPTION = "JLime Linux kernel for SuperH based Jornada 6xx"
3 LICENSE = "GPL"
4 PR = "r0"
5
6 SRCREV = "${AUTOREV}"
7
8 COMPATIBLE_HOST = "sh.*-linux"
9 #COMPATIBLE_MACHINE = "jornada6xx"
10
11 SRC_URI = "git://jlime.org/jlime-stable.git;protocol=git;branch=v2.6.25-stable"
12
13 S = "${WORKDIR}/git"
14
15 inherit kernel
16
17 #Lets let 3.4.x handle the compilation of this one
18 KERNEL_CCSUFFIX = "-3.4.4"
19
20 ARCH = "sh"
21 FILES_kernel-image = "/boot/${KERNEL_IMAGETYPE}*"
22
23 do_configure_prepend() {
24         install -m 0644 ${S}/config-hp6xx-2.6.25 ${S}/.config
25 }
26
27 do_deploy() {
28         install -d ${DEPLOY_DIR_IMAGE}
29         install -m 0644 arch/${ARCH}/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR}/images/${KERNEL_IMAGETYPE}
30 }