Merge branch 'vuplus-1.6' of 192.168.102.66:/var/ikseong/repo/openembedded into test_0921
[vuplus_openembedded] / recipes / linux / linux-dm8000_2.6.18.bb
1 require linux-opendreambox-2.6.18.inc
2
3 PR="${PR_INC}.0"
4
5 RDEPENDS += "dreambox-secondstage (>=83)"
6
7 SRC_URI += "\
8         file://linux-2.6.18-disable-unneeded-uarts.patch;patch=1 \
9         file://linux-2.6.18-use-full-flash.patch;patch=1 \
10 "
11
12 pkg_preinst_kernel-image_dm8000 () {
13         if [ -z "$D" ]; then
14                 mountpoint -q /boot && mount -o rw,remount /boot;
15                 if grep -q '^mtd3: 03c00000 ' /proc/mtd && ! grep -q '^legacy_flash_mapping=' /boot/secondstage.conf; then
16                         echo "enable legacy flash mapping in secondstage.conf";
17                         echo "legacy_flash_mapping=1;" >> /boot/secondstage.conf;
18                 fi;
19         fi;
20 }