[hbbtv/youtubetv] Fixed hanup bug and segmentation fault on 3rd-party images.
[vuplus_openembedded] / recipes / linux / linux-dm500plus.bb
1 DESCRIPTION = "Linux kernel for Dreambox DM500PLUS"
2 LICENSE = "GPL"
3 PN = "linux-dm500plus"
4 PV = "2.6.12"
5 PR = "r3"
6
7 # -rX is the patch revision - it's not related to this package's PR
8 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.12.tar.bz2 \
9         http://sources.dreamboxupdate.com/download/kernel-patches/linux-2.6.12-dream-ppc-r5.patch.bz2;patch=1;pnum=1 \
10         file://linux-2.6-trailing-whitespaces-in-params.patch;patch=1"
11
12 S = "${WORKDIR}/linux-2.6.12"
13
14 inherit kernel
15
16 FILES_kernel-image = "/boot/zImage.elf /boot/autoexec.bat"
17
18 export OS = "Linux"
19 ARCH = "ppc"
20 KERNEL_IMAGETYPE = "zImage"
21 KERNEL_OUTPUT = "arch/ppc/boot/images/zImage.elf"
22
23 do_configure_prepend() {
24         oe_machinstall -m 0644 ${S}/arch/ppc/configs/dm500plus_defconfig ${S}/.config || die "no default configuration for ${MACHINE} available."
25         oe_runmake oldconfig
26 }
27
28 do_install_append () {
29         install -d ${D}/boot
30         install -m 0755 arch/ppc/boot/images/zImage.elf ${D}/boot/zImage.elf
31         echo "/flash/bootlogo.elf" > ${D}/boot/autoexec.bat
32         echo "/flash/zImage.elf" >> ${D}/boot/autoexec.bat
33 }
34
35 pkg_preinst_kernel-image () {
36         [ -z "$D" ] && mountpoint -q /boot && mount -o rw,remount /boot
37         true
38 }
39
40 pkg_postinst_kernel-image () {
41         [ -z "$D" ] && mountpoint -q /boot && mount -o ro,remount /boot
42         true
43 }
44
45 pkg_prerm_kernel-image () {
46         [ -z "$D" ] && mountpoint -q /boot && mount -o rw,remount /boot
47         true
48 }
49
50 pkg_postrm_kernel-image () {
51         [ -z "$D" ] && mountpoint -q /boot && mount -o ro,remount /boot
52         true
53 }