1st commit working
[vuplus_openembedded] / recipes / linux / linux-bm750_3.1.1.bb
1 CRIPTION = "Linux kernel for vuplus"
2 LICENSE = "GPL"
3 KV = "3.1.1"
4
5 PR = "r0"
6
7 SRCREV = ""
8
9 #TODO : cpu proc patch
10
11 MODULE = "linux-3.1.1"
12
13 SRC_URI += "git:///home/shcheong/work/stb/sw/7413/refsw/git_linux/3.0/linux-3.1.1;protocol=file;branch=duo;tag=${SRCREV} \
14         file://fix_cpu_proc.patch;patch=1;pnum=1 \
15         file://${MACHINE}_defconfig \
16         "
17
18 #S = "${WORKDIR}/linux-${KV}"
19 S = "${WORKDIR}/git"
20
21 inherit kernel
22
23 FILES_kernel-image = "/boot/vmlinux.gz /boot/autoexec.bat"
24
25 export OS = "Linux"
26 KERNEL_IMAGETYPE = "vmlinux"
27 KERNEL_OUTPUT = "vmlinux"
28 KERNEL_OBJECT_SUFFIX = "ko"
29
30
31 do_configure_prepend() {
32         oe_machinstall -m 0644 ${WORKDIR}/${MACHINE}_defconfig ${S}/.config
33         oe_runmake oldconfig
34 }
35
36 kernel_do_install_append() {
37         install -d ${D}/${KERNEL_IMAGEDEST}
38         install -m 0755 ${KERNEL_OUTPUT} ${D}/${KERNEL_IMAGEDEST}
39         gzip ${D}/${KERNEL_IMAGEDEST}/${KERNEL_IMAGETYPE}
40 }
41
42 pkg_postinst_kernel-image () {
43         if [ -d /proc/stb ] ; then
44                 flash_eraseall -j /dev/mtd1
45                 nandwrite -p /dev/mtd1 /${KERNEL_IMAGEDEST}/${KERNEL_IMAGETYPE}.gz
46         fi
47         rm -f /${KERNEL_IMAGEDEST}/${KERNEL_IMAGETYPE}.gz
48         true
49 }
50