surpport seeking the recorded video
[vuplus_openembedded] / recipes / libsigc++-2.0 / libsigc++-2.0_2.0.17.bb
1 DESCRIPTION = "A library for loose coupling of C++ method calls"
2 SECTION = "libs"
3 PRIORITY = "optional"
4 PR = "r1"
5 LICENSE = "GPL LGPL"
6 SRC_URI = "ftp://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.0/libsigc++-${PV}.tar.gz \
7            file://define_sigc_api.patch;patch=1 "
8 S = "${WORKDIR}/libsigc++-${PV}"
9
10 inherit autotools pkgconfig
11
12 EXTRA_AUTORECONF = "--exclude=autoheader"
13
14 FILES_${PN}-dev += "${libdir}/sigc++-*/"
15
16 # acpaths = ""
17
18 do_stage() {
19         install -d ${STAGING_LIBDIR}/sigc++-2.0/include
20         install -m 0644 sigc++config.h ${STAGING_LIBDIR}/sigc++-2.0/include/
21         oe_libinstall -so -C sigc++ libsigc-2.0 ${STAGING_LIBDIR}
22
23         install -d ${STAGING_INCDIR}/sigc++-2.0/sigc++
24         for f in sigc++/*.h
25         do
26                 install -m 0644 $f ${STAGING_INCDIR}/sigc++-2.0/sigc++/
27         done
28         install -d ${STAGING_INCDIR}/sigc++-2.0/sigc++/functors
29         for f in sigc++/functors/*.h
30         do
31                 install -m 0644 $f ${STAGING_INCDIR}/sigc++-2.0/sigc++/functors
32         done
33
34         install -d ${STAGING_INCDIR}/sigc++-2.0/sigc++/adaptors
35         for f in sigc++/adaptors/*.h
36         do
37                 install -m 0644 $f ${STAGING_INCDIR}/sigc++-2.0/sigc++/adaptors
38         done
39         install -d ${STAGING_INCDIR}/sigc++-2.0/sigc++/adaptors/lambda
40         for f in sigc++/adaptors/lambda/*.h
41         do
42                 install -m 0644 $f ${STAGING_INCDIR}/sigc++-2.0/sigc++/adaptors/lambda
43         done
44
45
46 }
47