surpport seeking the recorded video
[vuplus_openembedded] / recipes / libpcre / libpcre-native_7.6.bb
1 SECTION = "unknown"
2 require libpcre_${PV}.bb
3 inherit native
4 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libpcre-${PV}"
5
6 # NOTE: multiple providers are available (libpcre, libpcre-native);
7 # NOTE: consider defining PREFERRED_PROVIDER_pcre
8 PROVIDES = ""
9
10 do_compile () {
11         # The generation of dftables can lead to timestamp problems with ccache
12         # because the generated config.h seems newer.  It is sufficient to ensure that the
13         # attempt to build dftables inside make will actually work (foo_FOR_BUILD is
14         # only used for this).
15         oe_runmake CC_FOR_BUILD="${BUILD_CC}" CFLAGS_FOR_BUILD="-DLINK_SIZE=2 -I${S}/include" LINK_FOR_BUILD="${BUILD_CC}"
16 }
17