surpport seeking the recorded video
[vuplus_openembedded] / recipes / libnet / libnet_1.1.2.1.bb
1 DESCRIPTION = "A packet dissection and creation library"
2 HOMEPAGE = "http://www.packetfactory.net/libnet/"
3 SECTION = "libs"
4 PRIORITY = "optional"
5 LICENSE = "BSD"
6 DEPENDS = "libpcap"
7 # There are major API changes beween libnet v1.0 and libnet v1.1
8 PROVIDES = "libnet-1.1"
9 PR = "r3"
10
11 SRC_URI = "${DEBIAN_MIRROR}/main/libn/libnet/libnet_${PV}.orig.tar.gz \
12            file://support-uclibc.patch;patch=1 \
13            file://fix-endianess-test.patch;patch=1 \
14            file://new-autotools.patch;patch=1"
15
16 S = "${WORKDIR}/libnet"
17
18 inherit autotools binconfig
19
20 do_configure_prepend() {
21         rm -f aclocal.m4 Makefile.am ltmain.sh
22 }
23 do_install_append () {
24         install -d ${D}${datadir}/man/man3/
25         install -d ${D}${bindir}
26         install -m 0644 ${S}/doc/man/man3/*.3 ${D}${datadir}/man/man3/
27         install -m 0755 ${S}/libnet-config ${D}${bindir}
28 }
29 do_stage () {
30         oe_runmake -C src 'DESTDIR=${STAGING_LIBDIR}' 'libdir=' install-libLIBRARIES
31         oe_runmake -C include 'DESTDIR=${STAGING_INCDIR}' 'includedir=' install-includeHEADERS
32         oe_runmake -C include/libnet 'DESTDIR=${STAGING_INCDIR}' 'includedir=' install-libnetincludeHEADERS
33 }
34
35 #static build
36 FILES_${PN} = ""
37 FILES_${PN}-dev += "${bindir}/libnet-config"
38
39 CPPFLAGS_prepend = "-I${S}/libnet/include "